[dev-italia] Osmosis e c#

sabas88 sabas88 a gmail.com
Mer 22 Gen 2014 08:06:55 UTC


Il giorno 22 gennaio 2014 07:59, Stefano Fraccaro <
postmaster a stefanofraccaro.org> ha scritto:

> Mi sto facendo un programmino c# console per generarmi dei file .poly
> delle città limitrofe. Mi sto scontrando con un problema inaspettato:
> eseguendo osmosis da terminale ottengo un risultato (giusto). Eseguendo
> osmosis con gli stessi parametri (copia e incolla) dal programma c# ottengo
> un file xml praticamente vuoto (solo il tag osm e bounds). Nome del file
> eseguibile e del file di input .pbf sono passati con percorso assoluto.
> Nello standard error non vedo segnalazione di errori.
> Qualcuno ha avuto problemi simili in passato? Può essere legato al modo in
> cui Mono esegue il fork del nuovo processo? Variabili di ambiente diverse?
>
>
Potresti provare a far stampare i risultati di osmosis su stdout e vedere
cosa fa...
http://stackoverflow.com/questions/878632/best-way-to-call-external-program-in-c-sharp-and-parse-output
Lo standard error leggi quello del tuo programma o quello di osmosis?
http://stackoverflow.com/questions/206323/how-to-execute-command-line-in-c-get-std-out-results


> --
> Stefano Fraccaro
> Web: http://www.stefanofraccaro.org
>
>
>
Ciao,
Stefano

>  _______________________________________________
> dev-italia mailing list
> dev-italia a openstreetmap.org
> https://lists.openstreetmap.org/listinfo/dev-italia
>
-------------- parte successiva --------------
Un allegato HTML è stato rimosso...
URL: <http://lists.openstreetmap.org/pipermail/dev-italia/attachments/20140122/f2313a06/attachment.html>


Maggiori informazioni sulla lista dev-italia