[OSM-dev] New version of tiles at home

Rhys Powell stanley12 at blueyonder.co.uk
Thu Dec 7 23:07:14 GMT 2006


Rhys Powell wrote:
> James R. Glasgow wrote:
>> I am having a problem with this new tiles at home script. when I run
>>
>> $ ./tilesGen.pl
>>
>> all I get is
>>
>>
>> Downloading: Request from server done, 23 bytes
>> OK, got something... (from the "grow" server module)
>> Doing zoom level 12, location 2116, 1380
>> Doing area around 50.485396,6.020508
>> Downloading: Map data to data-4971.osm done, 0 bytes
>> No data at this location
>> Trying smaller slices...
>> Downloading: Map data to data-4971-0.osm done, 0 bytes
>> No data here either
>>
>> and then it stops.  Is this because there is just no data for this
>> area and the other 20 areas it just tried, or is it a problem with the
>> script?
>>
>>
>> I also tried
>>
>> Doing zoom level 12, location 2141, 1396
>> Doing zoom level 12, location 2018, 1291
>> Doing zoom level 12, location 2007, 1307
>> Doing zoom level 12, location 2025, 1382
>> Doing zoom level 12, location 2108, 1356
>> Doing zoom level 12, location 2143, 1422
>>
>> etc...
> 
> I was getting the same issue as well as it failing on a bad interpreter 
> say that it was #!/usr/bin/perl^M which I couldn't grep out so I had to 
> copy the script apart from that top line.
> 
> So far to get it to connect to the server I have had to add into the script
> my $Niceness = "nice";
> my $OsmUsername = "username";
> my $OsmPassword = "password";
> 
> 
> but I have now run out of time. It appears, on my system at least, that 
> the main script is not reading in the conf file, it is readable by all 
> so there is some other underlying reason. Not sure if I will get to look 
> into that today, but I should get a chance to just hack it to get it to 
> run hopefully.
> 
> Cheers
> 
> Rhys

Yep the conf file was in dos format but converting failed for me so I 
transfered all the variables into the main script and it worked.

The issue with the black tiles appears to be inkscape, my problem came 
from my debian server (which is becoming the bain of my life) and it run 
inkscape version 0.41.1 (Nov 30 2005), (yep thats the date and coming 
from fedora why do people even consider debian). Sadly my lack of 
knowledge of how to get amd64 debian to point to testing and the lack of 
delivery of etch (due December) means I cannot confirm that this is the 
root of the issue but every other system that I have tried has produced 
no black tiles.

Cheers

Rhys






More information about the dev mailing list