[OSM-dev] Support for multiple layers on the tiles at home server

Frederik Ramm frederik at remote.org
Wed Apr 4 00:28:40 BST 2007


Hi Hakan,

> Cool, I want to get a medal for the first "real" maplint file ;-)

> http://dev.openstreetmap.org/~ojw/Tiles/maplint.php/12/2355/1568.png_details

lynx --dump 
http://dev.openstreetmap.org/~ojw/Tiles/maplint.php/12/2355/1568.png_details
api_1.0|EXISTS|1154|bytes|Hakan|1175640336|2007-04-03T23:45:36

lynx --dump 
http://dev.openstreetmap.org/~ojw/Tiles/maplint.php/12/2141/1404.png_details
api_1.0|EXISTS|5687|bytes|framm|1175633838|2007-04-03T21:57:18

Hum. Will a silver medal do ;-)? (But I had advance notice.)

> Frederik: I'm using the maplint styles you sent me some time ago, but my 
> "empty" maplint tiles are 759 bytes. Can you give me some hint where to 
> fix this? I'm not quite a XSL guru ;-)

I think the "empty tile detection" that Deelkar provided for tilesGen.pl 
relies on the background colour being #fcfcfc, and the style sheets I 
sent you have #f0f0f0 (in the .map-background style). Try changing that.

The maplint styles I did are very quick&dirty and I guess we'll see some 
refinement here once the layer takes off. The same is valid for the 
maplint checks themselves.

I'll provide a modified tilesGen.pl to create and upload the new layers 
tomorrow - or have you (Hakan) already tweaked my maplint tilesGen.pl to 
re-enable t at h mode?

Bye
Frederik

-- 
Frederik Ramm  ##  eMail frederik at remote.org  ##  N49°00.09' E008°23.33'




More information about the dev mailing list