[OSM-dev] Dealing with segements referencing deleted nodesinthe planet dump

80n 80n80n at gmail.com
Thu Jan 18 23:43:04 GMT 2007


On 1/18/07, Dean Earley <dean at earlsoft.co.uk> wrote:
>
> 80n wrote:
> > They are gone now.  I used the following method to make them dissappear:
> >
> > 1) Using JOSM, create a new segment nearby.
> >
> > 2) Select the offending way and add the newly created segment to the
> way.
> >
> > 3) Then remove all old segments from the way *except* for the newly
> > created segment.
> >
> > 4) Upload
> >
> > 5) Delete the way and newly created segment.
> >
> > 6) Upload
> >
> > I'm not sure why this works but it seems to do the job.
>
> It's just shifted it off to another (non existent) segment.
> I was reluctant to do that so it could actually be tracked down and
> fixed rather than hidden :)



As far as the API is concerned the way no longer exists.  It appears on no
bbox request, and a direct get of the way returns a 404.  That, in my book,
means it is deleted.  And from previous encounters with this kind of problem
there is no other way to do it.

>They do seem very persistent...

Not any more ;)

Can anyone have a poke around in the database and report back on what they
find?

80n

--
> Dean Earley, Dee (dean at earlsoft.co.uk)
>
> irc:    irc://irc.blitzed.org/
> web:    http://personal.earlsoft.co.uk
> phone:  +44 (0)780 8369596
>
> _______________________________________________
> dev mailing list
> dev at openstreetmap.org
> http://lists.openstreetmap.org/cgi-bin/mailman/listinfo/dev
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.openstreetmap.org/pipermail/dev/attachments/20070118/411183b2/attachment.html>


More information about the dev mailing list