[OSM-dev] JavaScript errors on slippy map in IE7

David Earl david at frankieandshadow.com
Thu Jun 14 15:37:02 BST 2007


Sebastian Spaeth wrote:
> -----BEGIN PGP SIGNED MESSAGE-----
> Hash: SHA1
> 
> Tom Hughes wrote:
>> In message <46703DC1.5010107 at frankieandshadow.com>
>>         David Earl <david at frankieandshadow.com> wrote:
>>
>>> As of sometime yesterday I think the slippy map on the home page is 
>>> producing javascript errors in IE7:
>>>    Line 40 Error 'undefined' is null or not an object
>> That was my faulty - well sort of anyway as my changes exposed an
>> existing problem. It should be fixed now.
> 
> Doe the slippy map work now in IE6 and 7? If that is the case, I would
> be happy if people commented on the tickets:
> 
> Ticket #330 IE7 Javascript error

As far as I can see there aren't any Javascript errors in normal use. 
There may be some special cases I haven't hit, but it is generally OK now.

> #430: Slippy map doesn't work in IE6

I just went back to an older Win 98 machine that has IE6 on it, and that 
works fine too.


> #79: IE doesn't show 'loading tile...' alt tags in slippy map

There is no 'loading tile' message anywhere, but you can see in the 
status bar that it is loading files. But I don't see a 'loading tile' 
message in Firefox either (where should I be looking?)

Mapnik tile display is useless in IE(7). It almost never shows the 
starting map in IE, and if you zoom in on osmarender and then switch to 
mapnik you sometimes get tiles - often not all - sometimes not. 
osmarender is nearly always OK. I suspect IE is downloading the tiles OK 
but not displaying them.

> #48: double click to centre slippy/tiles map broken in IE

It appear to zoom in one level and put the point where you clicked at 
the middle. Is that what is supposed to happen?

HTH

David




More information about the dev mailing list