[OSM-dev] Missing usernames on current data returned by API

Andy Robinson Andy_J_Robinson at blueyonder.co.uk
Tue Jun 19 12:04:39 BST 2007


Looking at Swaffham in Norfolk I find that a large quantity of the data that I know I placed in the database, especially nodes with some specific tags of mine have the following date and username:  timestamp='2007-01-10 18:39:59' user='jos逴뷸f’	'

Looking at the history data for node 21712237 for example:

<osm version="0.4" generator="OpenStreetMap server">
<node id="21712237" lat="52.6505113310016" lon="0.689199061772345" user="blackadder" visible="true" timestamp="2006-12-24T17:45:59+00:00">
<tag k="type" v="house"/>
<tag k="man_made" v="building"/>
<tag k="note" v="Formerly the home of Admiral Sir Arthur Knyvett Wilson V.C., First Sea Lord."/>
<tag k="name" v="Beech Cottage"/>
<tag k="created_by" v="JOSM"/>
</node>
<node id="21712237" lat="52.65051133" lon="0.68919906" visible="true" timestamp="2007-01-10T18:39:51+00:00">
<tag k="type" v="house"/>
<tag k="man_made" v="building"/>
<tag k="note" v="Formerly the home of Admiral Sir Arthur Knyvett Wilson V.C., First Sea Lord."/>
<tag k="name" v="Beech Cottage"/>
<tag k="created_by" v="JOSM"/>
</node>
</osm>

It would appear from the above that the only change on this item that occurred on 10th January related to a truncation of the lat and lon. Might that suggest it was done by something automatically?? At the same time the username for this change was not set which is presumably the reason for the odd username returned by the API for the current data.

Question therefore.. Might it be worth checking the db for missing usernames on the last edit and where the lat/lon was truncated but no other change was made perhaps the username of the pervious edit in history should be applied.

Cheers

Andy

Andy Robinson
Andy_J_Robinson at blueyonder.co.uk 







More information about the dev mailing list