[OSM-dev] (no subject)

Nick Whitelegg Nick.Whitelegg at solent.ac.uk
Thu Mar 8 10:43:16 GMT 2007


>Hi Nick,
>Can you connect to postgres using psql:

># psql freemap -U nick -W -h localhost -p 5432

>If you get the same error connecting from the psql client, its
>probably a problem with pg_hba.conf.  Mine is set like:


># TYPE  DATABASE    USER        CIDR-ADDRESS          METHOD

>local   all         all                          trust

># IPv4 local connections:
>host    all         all         127.0.0.1/32          md5

>So any machines on my local network can connect with an md5 encrypted
>password.  You set the password for the user at account creation time
>using:

>create user foo with encrypted password 'blah'.

Hello Nick,

OK thanks. I can't access my server right now, will be unable to until 
around 7pm tonight, but I know I can connect successfully using psql with 
a command such as:

# psql freemap

For example, when I put the OSM data into the database I did something 
like:

# psql freemap < planet-070228.sql

and that worked.

I guess it's more of a problem with how I've specified the connection in 
the Mapnik XML file. Maybe it should be "127.0.0.1" not "localhost"?

Nick









More information about the dev mailing list