[OSM-dev] osm2pgsql on Freemap: Mapnik rendering not working

Nick Whitelegg nick at hogweed.org
Sat Oct 20 12:33:53 BST 2007


Hello everyone,

(cc to Artem and Jon B. as I thought you might be able to help out here...)

Managed to successfully import the 03/10/07 planet.osm (the last 0.4 planet) 
directly into the PostGIS database I have on the Freemap server using 
osm2pgsql (the last 0.4 version, checked out on 06/10/07). I ran osm2pgsql on 
the Freemap server; it completed without any error messages.

However my Mapnik-based rendering software no longer renders the data 
successfully. It shows the SRTM contour data but no OSM data (I don't get 500 
errors etc) I'm using the same mapnik I did previously (one from March; 
haven't updated it as I ran into problems compiling later versions). I'm 
guessing the structure of the database has changed compared to that defined 
in March, but it seems to be more or less the same. The last planet I 
successfully imported into Freemap was the 15/08/07 planet; that was using 
the version of osm2pgsql which simply wrote out SQL and stored all the nodes 
and segments in huge arrays (think it dated from March, again)

Can anyone give me any pointers what might be wrong? Didn't get any error 
messages written out when I run my (CGI) rendering software on the 
command-line. 

My Mapnik configuration file is at

http://www.free-map.org.uk/stuff/osmmerc.xml

The source code to my rendering software is in:

http://www.free-map.org.uk/stuff/render

I also have (part of) the database dump at

http://www.free-map.org.uk/stuff/freemap.dump

which indicates stuff did get into the database.

Thanks,
Nick




More information about the dev mailing list