[OSM-dev] osmosis applied to latest planet

Brett Henderson brett at bretth.com
Fri Oct 26 08:34:34 BST 2007


I'm at a bit of a loss.

I downloaded the problem area from the api and imported it into a local 
database.  I then dumped the db as a changeset.  The data doesn't get 
corrupted anywhere.  Something is different when running on the 
production servers but I don't know what.  I've tried running it on both 
my windows laptop (codepage 1252 I believe) which has utf8 settings 
applied in my.cnf and my linux server which seems to be set to a utf8 
console but not defaulted to utf8 in my.cnf but with the database 
instance itself created with the utf8 encoding.
In both cases the data can be imported and dumped successfully without 
utf8 loss.

I've attached two files showing the data around way 4810727 as extracted 
by grep, problem-api.txt is the data returned by the api, 
problem-diff.txt is the data in the osmosis diff from 
planet.openstreetmap.org.  problem-api.txt is correct, problem-diff.txt 
is incorrect.

Short of running additional tests on the production environment I don't 
know what to try next.  There must be a difference between the debian 
osm servers and my fedora and windows environments.

Brett Henderson wrote:
> You crazy Europeans with your fancy characters.  What's wrong with 
> good old ASCII ;-)
>
> Could take a me a bit of time to test this.  I hope to get a chance 
> this evening (in 10 hours or so).
>
> I'll download a small area from the api, import it into a blank db, 
> then dumb the db as a change.  Hopefully I can replicate the error.  
> I'm a bit surprised to be honest, I thought I'd fixed the last of the 
> utf-8 issues a while ago.  Apparently not.
>
> Cheers,
> Brett
>
> Colin Marquardt wrote:
>> Christopher Schmidt <crschmidt at metacarta.com> writes:
>>
>>  
>>> http://labs.metacarta.com/osm/ is running planet + the osmosis patch 
>>> from a few hours ago... I think. If someone could check out an area 
>>> they
>>> edited after the plaent dump yesterday, and tlel me if they see it, in
>>> the map, that would be great.
>>>     
>>
>> The update itself worked nicely, and it's great to see changes so
>> fast.
>>
>> As discussed on IRC though, I see UTF-8 brokenness on recent data,
>> e.g.:
>>
>> http://labs.metacarta.com/osm/?zoom=15&lat=6535207.80143&lon=1226481.65939&layers=B00 
>>
>>
>> <way id="4810727" visible="true" 
>> timestamp="2007-10-24T23:52:39+01:00" user="ColinMarquardt">
>>
>> Christopher asked me to bring it up here.
>>
>> Cheers
>>   Colin
>>
>>
>> _______________________________________________
>> dev mailing list
>> dev at openstreetmap.org
>> http://lists.openstreetmap.org/cgi-bin/mailman/listinfo/dev
>>   
>
>

-------------- next part --------------
An embedded and charset-unspecified text was scrubbed...
Name: problem-api.txt
URL: <http://lists.openstreetmap.org/pipermail/dev/attachments/20071026/4b000b4e/attachment.txt>
-------------- next part --------------
An embedded and charset-unspecified text was scrubbed...
Name: problem-diff.txt
URL: <http://lists.openstreetmap.org/pipermail/dev/attachments/20071026/4b000b4e/attachment-0001.txt>


More information about the dev mailing list