[OSM-dev] mapnik projection problems?

Jon Burgess jburgess777 at googlemail.com
Fri Aug 15 15:29:08 BST 2008


2008/8/15 Mikel Maron <mikel_maron at yahoo.com>:
>
>  From: Jon Burgess <jburgess777 at googlemail.com>
>>>
>>> Seeing an issue with mapnik rendering of our map in Bethlehem. Bethlehem
>>> is
>>> located at about 31.717, 35.2.
>>>
>>> http://westbank.freemap.in/?lat=31.717&lon=35.2&zoom=11&layers=B
>>>
>>> However Bethlehem is showing up at a lower latitude in the mapnik
>>> rendering.
>>>
>>> http://westbank.freemap.in/?lat=31.523&lon=35.179&zoom=11&layers=B
>>>
>>> Our data is definitely in the correct spot, it's the rendering that's
>>> off. I
>>> suppose this is a projection misconfiguration in mapnik or mod_tile.
>>> Does anyone have any hints on what specifically I should look at?
>>
>>Which version of osm2pgsql do you use?
>>The common problem with older versions is forgetting to supply the
>>'-m' option while importing the data. This option is enabled by
>>default in later versions.
>
> Yes, it's an older version, and '-m' wasn't being used.
>
> However, now there's no map data being displayed at all!

If you are running the import as a different user to the renderer then
you may need to grant select access on the planet_osm_* tables to the
user doing the rendering (or 'public'). The current code does this
automatically, the version you are using might not.

You also need to make sure you restart the render daemon after
reloading the data.

-- 
 Jon




More information about the dev mailing list