[OSM-dev] Problem making database on current rails_port

Tom Hughes tom at compton.nu
Fri Feb 1 13:56:48 GMT 2008


In message <200802011252.43443.nick at hogweed.org>
        Nick Whitelegg <nick at hogweed.org> wrote:

> Hello everyone,
>
> Having difficulty making the database with the rails port (checked out about 
> an hour ago).
>
> When I do
>
> rake db:migrate
>
> I get:
>
> Uninitialized constant CGI::Session::SessionStore

No idea, what is causing that, but you don't want to migrate to the
current schema version anyway. Do this instead:

  rake db:migrate VERSION=10

The reason is that Nick put new migrations in last week but there is
no API code to go with them so you want to stick at version 10 which
it the current live schema version.

Tom

-- 
Tom Hughes (tom at compton.nu)
http://www.compton.nu/




More information about the dev mailing list