[OSM-dev] osmlib - which version of libxml

Nick Black nickblack1 at gmail.com
Wed Feb 27 13:00:02 GMT 2008


So you need libxml-ruby 0.5.3 to run the magic.

On Wed, Feb 27, 2008 at 12:47 PM, Nick Black <nickblack1 at gmail.com> wrote:
> Hello,
>
>  I can't get into the osmlib list, so I'm asking here.  I last used
>  osmlib before christmas, but today it isn't working:
>
>  $ osmexport 01_major_secondary.oxr  putney.osm /output/
>  /sw/lib/ruby/gems/1.8/gems/GeoRuby-1.3.2/lib/geo_ruby/simple_features/geometry.rb:22:
>  warning: method redefined; discarding old srid=
>  /sw/lib/ruby/gems/1.8/gems/osmlib-base-0.1.2/lib/OSM/StreamParser.rb:38:
>  uninitialized constant XML::SaxParser::Callbacks (NameError)
>
>  I thought this is an issue with libxml-ruby's new SAX paraser
>  callbacks.  I'm using libxml-ruby 0.3.8.4 on Ubuntu & Mac.
>
>  Do I need to update to 0.5.2 or 0.5.3?
>
>
>  --
>  Nick Black
>



-- 
Nick Black
--------------------------------
http://www.blacksworld.net




More information about the dev mailing list