[OSM-dev] mod_tile / renderd issue

Jon Burgess jburgess777 at googlemail.com
Tue May 13 00:02:53 BST 2008

On Mon, 2008-05-12 at 08:57 -0500, Wayne Walker wrote:
> Jon,
> Thank you for the information.  Given that it is rendering and storing
> in the .meta file,  How do I troubleshoot why it is not being served
> from the .meta file (everytime I visit http://tiles/osm_tiles2/1/1/1.png,
> renderd goes through rendering again)

If you've got requests coming through from Apache into the renderd and
it is producing .meta files then you're already 90% of the way there.

I think you're strace approach is a good one but you need to do it on
the Apache process to figure out why mod_tile can not access the .meta
files. It will only request the tile to be rendered if it can not read
it (or it thinks it is too old). It might be best to limit Apache to 1
or 2 processes while debugging it

If I had to take a wild guess I'd say that the problem is one of:-
- Apache / mod_tile is failing to read the file due to a permission
problem preventing access to the .meta files
- Something like SELinux is blocking the file access (this often blocks
the unix socket to the render daemon).
- You've changed some of the settings in render_config.h but have not
recompiled & installed mod_tile with these changes (and then restarted
- Perhaps you tried setting METATILE to something other than 8. I don't
think I've tried any alternate settings recently. Things might break if
you change it (especially if renderd and mod_tile have different

There are some debug statements in mod_tile which are commented out,
search for ap_log_rerror in mod_tile.c. Most of these concern the input
side of the request processing which you already seem to have working so
I think these won't offer too much help.


More information about the dev mailing list