[OSM-dev] Database Schema

sagar anand sagaranand.er at gmail.com
Thu Oct 9 04:37:39 BST 2008

Hi All

I am trying to replicate the database schema of openstreet map on MySQL
server running on Fedora Ver 9.
I am almost through to all stages but seems I am not getting the resolution
for the last stage where it says rake db: migrate

This was the first error I got:

*Missing the Rails 2.0.2 gem. Please `gem install -v=2.0.2 rails`, update
your RA
ILS_GEM_VERSION setting in config/environment.rb for the Rails version you
do ha
ve installed, or comment out RAILS_GEM_VERSION to use the latest version

*What i did:

*I thought I need to update gems

So I ran :
gem update  --system
gem install rails

I think I updated gems from 0.8.5 to 1.3.0

Now when I try running
rake db :migrate
I got some error *that said  I need to comment out use version 2.0.2 in
*Did that

*Now when I tried running rake db : migrate again
It is coming with this error:

*can't activate activerecord (= 2.0.2, runtime), already activated

rake db:migrate at the root of rails directory. I got a error saying I need
to comment out

I am kind of stuck witht his issue and I a unable to find a resolution. We
are making a project for World Vision which can use openstreetmap as theor
Geographical Information System.

Any suggestions will be higly appreciated.

Thanks & Regards
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.openstreetmap.org/pipermail/dev/attachments/20081009/3f92d0a2/attachment.html>

More information about the dev mailing list