[OSM-dev] Osm2pgsql - Planet.osm fail - "Unknown Element name : changeset"

Quy phan quyminhphan at hotmail.com
Tue Dec 22 21:51:55 GMT 2009

Hey Peter, I got your Centos Binary, changemod it, got it to run,
but when i run it, i get an error:
$ ./osm2pgsql-r19130-centos5 
./osm2pgsql-r19130-centos5: error while loading shared libraries: libgeos-3.1.0.so: cannot open shared object file: No such file or directory

complaning about libgeos and cannot open the shared object file,
I tried doing yum install geos 
any good step by step instructions for centos out there on how to configure osm2pgsql to work
and it said I got the latest version, any help would be much appreciated, thank you!

> From: jburgess777 at googlemail.com
> To: osm-lists at mazdermind.de
> Date: Thu, 17 Dec 2009 22:05:44 +0000
> CC: dev at openstreetmap.org
> Subject: Re: [OSM-dev] Osm2pgsql - Planet.osm fail - "Unknown Element name : changeset"
> On Thu, 2009-12-17 at 11:44 +0100, Peter Körner wrote:
> > >> Changesets are only included in planet.osm since a few weeks, right? As the file linked in the wiki is from July, it will not help him.
> > 
> > How is osm2pgsql compiled on windows? What Software do I need? Will VC++ 
> > Express do it?
> The version I provided was cross-compiled from Fedora using the mingw32
> tools. The osm2pgsql code itself should be fairly simple to compile, you
> are more likely to run into difficulties getting the dependencies
> compiled or installed.
> 	Jon
> _______________________________________________
> dev mailing list
> dev at openstreetmap.org
> http://lists.openstreetmap.org/listinfo/dev
Hotmail: Free, trusted and rich email service.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.openstreetmap.org/pipermail/dev/attachments/20091222/eb0dd5bd/attachment.html>

More information about the dev mailing list