[OSM-dev] Planetfile with ChangeSet

Frederik Ramm frederik at remote.org
Tue Jun 2 16:13:31 BST 2009


Hi,

m2huber at hsr.ch wrote:
> As we firstly tried to Run the program with the newest planet file we discovered a problem with the changesets. After your mail I also tried the import the latest planet with osmosis and it didn't work either. I don't know what exactly the problem is, but I guess that there could be a Problem with the formattation of the XML File?

The XML file looks fine to me. Your Osmosis complains about an error in 
line 4319 of planet-090520. I have:

% bzcat planet-090520.osm.bz2 |head -4319|tail -1
   <changeset id="4316" created_at="2007-04-01T13:41:04Z" 
closed_at="2007-04-01T17:28:47Z" open="false" min_lon="-7.0227251" 
min_lat="53.1442826" max_lon="-6.1289473" max_lat="54.0376818" 
user="mackerski" uid="6367"/>

Which looks perfectly all right! May I suggest:

1. Take the md5 sum of your planet file and compare with the one on the 
download server (to check if the file has downloaded correctly).

2. Do you read the bz2 file directly from your app, or do you uncompress 
it first? Because there have been issues with compressed files before. 
If you try to use bzcat to pipe the file into osmosis (then use 
"file=-"), does that perhaps work better?

Bye
Frederik




More information about the dev mailing list