[OSM-dev] osmosis 0.31.1 not starting

Brett Henderson brett at bretth.com
Tue May 26 04:14:21 BST 2009


Hanno Böck wrote:
> Hi,
>
> I'm maintaining a gentoo package for osmosis. Now, with latest 0.31.1 version 
> I get this when just trying to start osmosis:
>
> hanno at libertalia ~/semester/linopt/ue $ osmosis
> 25.05.2009 16:13:39 org.openstreetmap.osmosis.core.Osmosis run
> INFO: Osmosis Version 0.31.1
> 25.05.2009 16:13:39 org.openstreetmap.osmosis.core.Osmosis main
> SCHWERWIEGEND: Execution aborted.
> java.lang.NoClassDefFoundError: org/java/plugin/JpfException
>         at org.openstreetmap.osmosis.core.Osmosis.run(Osmosis.java:73)
>         at org.openstreetmap.osmosis.core.Osmosis.main(Osmosis.java:30)
> Caused by: java.lang.ClassNotFoundException: org.java.plugin.JpfException
>         at java.net.URLClassLoader$1.run(URLClassLoader.java:200)
>         at java.security.AccessController.doPrivileged(Native Method)
>         at java.net.URLClassLoader.findClass(URLClassLoader.java:188)
>         at java.lang.ClassLoader.loadClass(ClassLoader.java:307)
>         at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:301)
>         at java.lang.ClassLoader.loadClass(ClassLoader.java:252)
>         at java.lang.ClassLoader.loadClassInternal(ClassLoader.java:320)
>         ... 2 more
>   
It sounds like the classpath isn't being setup correctly.  Can you 
modify the osmosis launch script and add this statement:
echo $EXEC
just before the exec statement
exec $EXEC

That should tell us why the jpf-1.5.jar file isn't being found by osmosis.





More information about the dev mailing list