[OSM-dev] 090916 Missing Nodes

Mark Granger grangerfx at gmail.com
Fri Sep 18 02:41:59 BST 2009


Sorry Outlook sent my message before I was finished.  As I was saying...

Looking at the first missing node 24490963:

http://www.openstreetmap.org/browse/node/24490963

referenced by way 4187296:

http://www.openstreetmap.org/browse/way/4187296

The node is clearly in the database.

Here are the relevant lines from planet-090916.osm:

  <node id="24490962" version="9" timestamp="2008-07-12T15:25:07Z" uid="44659" user="Phil Shipley" changeset="470842" lat="62.6606981" lon="6.350138">
    <tag k="created_by" v="almien_coastlines"/>
    <tag k="source" v="PGS(could be inacurately)"/>
  </node>
  <node id="24490964" version="2" timestamp="2008-08-02T12:15:14Z" uid="44659" user="Phil Shipley" changeset="19938" lat="62.6483328" lon="6.3520899">
    <tag k="created_by" v="almien_coastlines"/>
    <tag k="source" v="PGS(could be inacurately)"/>
  </node>

As you can see, 24490963 should be between 244090962 and 24490964 but has gone AWOL. Since the same node is missing in two different versions of the planet file, this indicates that it is getting lost during export.

Remember that these planet files are from the hypercube server which merges the daily updates with the weekly planet file from the main server. The problem could be with the program that merges the updates or it could be in the code that exports the weekly planet file.

Anyway, I hope this helps.

-Mark Granger
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.openstreetmap.org/pipermail/dev/attachments/20090917/d1171a6b/attachment.html>


More information about the dev mailing list