[OSM-dev] ./generate_image.py returns error

Sajjad Anwar sajjadkm at gmail.com
Sun Aug 29 15:37:48 BST 2010


Hi,

I'm trying to setup mapnik again and stuck. This is what I have done so far:

1. Setup the pgsql db named cal_l10n
2. Checked out from Mapnik SVN.
3. Setup Mapnik
4. Ran ./generate_image.py --dbname 'cal_l10n'
This return the following error:

inc/entities.xml.inc:9: parser warning : PEReference: %layers; not found
%layers;
        ^
Traceback (most recent call last):
  File "./generate_image.py", line 37, in <module>
    mapnik.load_map(m,mapfile)
RuntimeError: XML document not well formed:
Entity 'layer-admin' not defined (encountered in file 'osm.xml' at line
6571)

5. tried re creating the osm.xml file using ./generate_xml.py, but getting
the same error.

What could be wrong?

Regards.
-- 
Sajjad Anwar | http://geohackers.in | Blog: http://sajjad.in | Twitter:
geohacker
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.openstreetmap.org/pipermail/dev/attachments/20100829/c0c209e7/attachment.html>


More information about the dev mailing list