[OSM-dev] foreign key constraint violation in live-api

IgnacioZ zignacio at gmail.com
Tue May 4 12:36:32 BST 2010


They were done in a for loop and before I start the next request, I receive
the answer, though by looking at my code it could happen that two requests
are done in parallel, after receiving the Id of the previous one, I continue
and the previous connection may not have been finalized (they are different
instances).

Do you think that could be the reason ?



On Tue, May 4, 2010 at 8:29 AM, Tom Hughes <tom at compton.nu> wrote:

> On 04/05/10 12:16, IgnacioZ wrote:
>
>>  >How do you plan to do that before you know what the bug is?
>>
>> By looking at the code...
>>
>
> Good luck with that...
>
>
>   >If you do what I asked and file a ticket in trac with the information
>> I requested, or even provide that information here, then I might
>> actually be able to tell you what the problem is.
>>
>> I will provide it here:
>>
>> URL:
>> http://api.openstreetmap.org//api/0.6/node/create
>>
>> HTTP Method: POST
>>
>> XML:
>> <osm><node changeset="4588121" lat="-31.428261" lon="-64.186582"><tag
>> k="name" v="Beto's"/><tag k="amenity" v="fast_food"/></node></osm>
>>
>> If you take a look at that changeset you will see that there are other
>> elements that where added correctly.
>>
>
> Am I right in suspecting that you were uploading multiple objects in
> parallel by sending different requests on different connections?
>
> Tom
>
> --
> Tom Hughes (tom at compton.nu)
> http://compton.nu/
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.openstreetmap.org/pipermail/dev/attachments/20100504/d78cbac6/attachment.html>


More information about the dev mailing list