[OSM-dev] Rails 1.8.6 dependency on OSM Rails Port & "sanitize"

Brendan Morley morb.gis at beagle.com.au
Sun Sep 5 00:40:16 BST 2010


Hi all

I just want to confirm something...

The wiki page 
http://wiki.openstreetmap.org/w/index.php?title=The_Rails_Port states:


          Prerequisites/Dependencies

    The dependencies aren't particularly stretching for any linux
    distribution, and are roughly:

        * Ruby 1.8.4 or higher.

Given I've just been trying to deploy today's git clone on a CentOS 5.4 
box with little progress, I just wanted to note:

1. The git commit 
http://git.openstreetmap.org/?p=rails.git;a=commit;h=94f19ce3b32d70c499893f8ffb9592a9f0a54f7a 
way back in March introduces the "sanitize" gem, of which any version 
1.1+ appears to require ruby 1.8.6
2. It's fairly difficult to get a ruby 1.8.6 RPM for CentOS 5.4, 
especially if it's x86_64


I'm very tempted to go straight into the wiki page and adjust it, but 
wanted to check to see if I haven't missed anything simple.


Brendan
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.openstreetmap.org/pipermail/dev/attachments/20100905/b88555b8/attachment.html>


More information about the dev mailing list