[OSM-dev] applying hourly OSM diffs with osmosis gradually messes up database

Daniel Behr daniel.behr at hzg.de
Mon Aug 1 10:16:09 BST 2011


Hello,
my first email to the OSM list and I hope someone had this problem 
before (and solved it). I have OSM Europe data in postgres 8.4.7/postgis 
1.5.2 and render tiles with mapnik0.7.1. this actually works fine, until 
I apply the hourly diffs from 
http://planet.openstreetmap.org/hour-replicate in a bunch once per day 
with osmosis [1]. It usually takes about 4-5 hours to finish. After a 
few days of updates I get errors in the rendered images. It seems to 
affect only line features (roads, borders, railways) in a way that 
random gaps appear [2]. I've also seen that some linenodes jumped for 
several hundred kilometers [3].

I already re-imported europe.osm and its still the same after some days 
of updates.
I dont necessary need the hourly diffs, I just dont want to fall months 
behind with my map. So if there is no easy fix for this problem, I would 
rather re-import europe.osm monthly or bi-monthly and render a new set 
of tiles then. This means I would have to cache all 20 zoomlevels to be 
able to provide tiles while doing the re-import, which would be a bit of 
a drawback... (level 17 still rendering after 4 days. 18? 19?)

I am no postgres ace and I only tried reindexing tables and vacuum DB, 
without any result. I dont even know if the problem is with osmosis or 
the database setup (or other)?

will be happy about any pointers.

cheers
Daniel

[1]
osmosis --rri workingDirectory=/var/lib/pgsql/.osmosis --simc 
--write-xml-change "-" |\
  /opt/osm2pgsql/osm2pgsql -s -a -b "-3500000,3720000,5080000,11940000"\
  --tablespace-main-data europe --tablespace-main-index europe 
--tablespace-slim-data europe --tablespace-slim-index europe\
  -d osm -C 4096 -S /opt/osm2pgsql/default.style -

osmosis config:
baseUrl=http://planet.openstreetmap.org/hour-replicate
maxInterval = 90000

[2]
http://kofserver3.hzg.de/error1.png
[3]
http://kofserver3.hzg.de/error2.png



More information about the dev mailing list