[OSM-dev] White squares in sea inEurope

Erik Johansson emj at kth.se
Fri Dec 9 10:14:30 GMT 2011


On Thu, Dec 8, 2011 at 23:19, yvecai <yvecai at gmail.com> wrote:
> On 08. 12. 11 21:54, Erik Johansson wrote:
>>
>> On Thu, Dec 8, 2011 at 17:49, yvecai<yvecai at gmail.com>  wrote:
>>>
>>> On 07. 12. 11 20:26, yvecai wrote:
>>>>
>>>> I've already seen here and there the effect of a broken coastline, but
>>>> we
>>>> have something different in that server:
>>>> http://osmati.net/osmand/map?zoom=3&lat=53.98194&lon=23.90625&layers=B
>>>> I hope somebody has already seen something like this.
>>>>
>>>> We are trying to setup a tile server to reduce tile requests on the main
>>>> server from the Osmand Android app.
>>>> Setup is the following:
>>>> Debian 5, postgresql 8.3
>>>> Mapnik 0.7.1
>>>> osm.xml from svn 19/11/2011
>>>>
>>>> Please don't zoom that much (not>  11), we are still facing issues with
>>>> renderd troughput, I may come back on that later.
>>>>
>>>> Yves
>>>
>>> I said don't zoom>  11!  :)
>>>  Ok, I limit the zoom in OpenLayers. No idea about the white squares,
>>> anybody?
>>
>> Which coastline shapefile do you use?
>
> I figure out that I was using one from one year ago! With a fresh one, it's
> ok now.
> Thanks!

Interesting I would have thought the problem would have been more
intricate than that. I wonder if that old shapefile ever worked.

It looked like it had been "optimized in someway" removing all square
water polygons or something.

/Erik
-- 
/emj



More information about the dev mailing list