[OSM-dev] rails_port problem
bestoujev at gmail.com
Wed May 4 15:56:25 BST 2011
Synaptic shows me only ruby 4.5 metapackage and ruby1.8... I'll try to
uninstall them both and install 1.8 manually...
On 04.05.2011 18:44, Tom Hughes wrote:
> On 04/05/11 15:42, Kirill Bestoujev wrote:
>> no way to downgrade - libxml-ruby is 1.1.3-2 and ruby itself is 1.8.7
> Well in that case I'm stumped as that Reader#expand error is, as far as
> I know only possible with ruby 1.9. Here's where the fix Matt Amos did
> for it was accepted into libxml-ruby:
>> On 04.05.2011 18:30, Tom Hughes wrote:
>>> On 04/05/11 15:27, Kirill Bestoujev wrote:
>>>> If the error is harmless then why this error causes the api to fail on
>>>> my machine? This is the only error I get in rails log.
>>> It's not the only error though - you also reported this:
>>> "Document is not accessible to Ruby (hint - did you call Reader#expand?)"
>>> Which I've now been told on IRC is the result of a bug in the libxml
>>> bindings (at least in the v2.x ones) when used with ruby 1.9.
>>> So downgrading libxml-ruby will probably fix it. Using ruby 1.9 is
>>> probably not recommended though as we don't test with that at all and I
>>> believe it is quite different to 1.8 in some ways.
More information about the dev