[OSM-dev] osm2pgsql on old GEOS versions

Paul Norman penorman at mac.com
Sat Jan 10 22:26:18 UTC 2015


osm2pgsql currently has some code for supporting geos 2.2, which I'm 
proposing to remove 
(https://github.com/openstreetmap/osm2pgsql/pull/251). There is not any 
testing of osm2pgsql with versions of geos that old, and old versions of 
geos are known to cause errors with geometry processing at times.

I'm interested if anyone is using geos 2.x, 3.0 or 3.1 with osm2pgsql. 
If you are running Ubuntu 12.04 or later with geos from packages, you 
are using a newer version. On most systems you can find out your geos 
version with geos-config --version. I'm also not interested in usage 
data about geos 3.2 - I know that is sometimes used, and sometimes 
causes problems.





More information about the dev mailing list