[OSM-dev] Release candidate for new osm2pgsql 0.88.0 stable release

Paul Norman penorman at mac.com
Sat Feb 27 16:57:46 UTC 2016


On 2016-02-27 5:12 PM, Sebastiaan Couwenberg wrote:
> Switching the Debian packaging to CMake was trivial, and allowed the
> removal of custom install rules.
>
> The biggest difference is that /usr/bin/nodecachefilereader is no longer
> installed, but it's sources are still included and built. The renamed
> node-persistent-cache-reader is just not installed any more. PR #544 has
> a fix:https://github.com/openstreetmap/osm2pgsql/pull/544
We ended up removing nodecachefilereader 
(https://github.com/openstreetmap/osm2pgsql/pull/545), as it is no 
longer useful. It was developed for the initial testing of flat nodes, 
and hasn't been properly maintained in years.

I haven't written the release notes, but the 0.90.0 release is the last 
one that will support PostGIS 1.5.



More information about the dev mailing list