<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.0 Transitional//EN">
<HTML><HEAD>
<META http-equiv=Content-Type content="text/html; charset=utf-8">
<META content="MSHTML 6.00.2800.1106" name=GENERATOR>
<STYLE></STYLE>
</HEAD>
<BODY bgColor=#ffffff>
<DIV><FONT size=2>Hi,</FONT></DIV>
<DIV><FONT size=2></FONT> </DIV>
<DIV><FONT size=2>today, I installed the new ActiveState ActivePerl with GD and 
GD::Image Packages and it seems to be running. Now, I can see a lot of nice 
looking tiles in my working directory c:/temp! :-)</FONT></DIV>
<DIV><FONT size=2>Then I tried to upload my rendered tiles with the command 
"perl upload.pl", but that shows me the following failure:</FONT></DIV>
<DIV><FONT size=2></FONT> </DIV>
<DIV><FONT size=2>C:\tiles@home>perl upload.pl</FONT></DIV>
<DIV><FONT size=2>[#0   0%   upload] Got 683 files 
<971239 bytes>, compressing... The system cannot find the path 
sepecified.</FONT></DIV>
<DIV><FONT size=2>'rm' is not recognized as an internal or external 
command,</FONT></DIV>
<DIV><FONT size=2>operable program or batch file.</FONT></DIV>
<DIV><FONT size=2>[#0   0%   upload] Uploading 
c:\temp\uploadable/1177242030_3272_0.zip... Can't open</FONT></DIV>
<DIV><FONT size=2>file c:\temp\uploadable/1177242030_3272_0.zip: No such file or 
directory at</FONT></DIV>
<DIV><FONT size=2>C:/Perl/lib/LWP/UserAgent.pm line 430</FONT></DIV>
<DIV><FONT size=2></FONT> </DIV>
<DIV><FONT size=2>C:\tiles@home></FONT></DIV>
<DIV><FONT size=2></FONT> </DIV>
<DIV><FONT size=2>How can I solve my upload problems?</FONT></DIV>
<DIV><FONT size=2>Thanks a lot and have a nice day</FONT></DIV>
<DIV><FONT size=2></FONT> </DIV>
<DIV><FONT size=2>Akio</FONT></DIV>
<DIV><FONT size=2></FONT> </DIV>
<DIV style="FONT: 10pt arial">----- Original Message ----- 
<DIV style="BACKGROUND: #e4e4e4; font-color: black"><B>From:</B> <A 
title=akio.hansen@t-online.de href="mailto:akio.hansen@t-online.de">Hansen</A> 
</DIV>
<DIV><B>To:</B> <A title=dev@openstreetmap.org 
href="mailto:dev@openstreetmap.org">dev@openstreetmap.org</A> </DIV>
<DIV><B>Sent:</B> Sunday, April 22, 2007 11:25 AM</DIV>
<DIV><B>Subject:</B> Re: [OSM-dev] Problems with <A 
href="mailto:Tiles@Home">Tiles@Home</A> under Windows</DIV></DIV>
<DIV><BR></DIV>
<DIV><FONT size=2>Hi,</FONT></DIV>
<DIV><FONT size=2></FONT> </DIV>
<DIV><FONT size=2>thanks for your help, but I can't install GD::Image via the 
PPM Console. If I start the PPM Manager in the Windows command line and use PPM 
to install GD::Image, it stops with the following error:</FONT></DIV>
<DIV><FONT size=2></FONT> </DIV>
<DIV><FONT size=2>C:\>ppm</FONT></DIV>
<DIV><FONT size=2>PPM interactive shell <2.2.0> - type 'help' for 
available commands.</FONT></DIV>
<DIV><FONT size=2>PPM> install GD-Image-AnimatedGif</FONT></DIV>
<DIV><FONT size=2>Install package 'GD-Image-AnimatedGif?' <y/N>: 
<</FONT></DIV>
<DIV><FONT size=2>Installing package 'GD-Image-AnimatedGif'...</FONT></DIV>
<DIV><FONT size=2>Error installing package 'GD-Image-AnimatedGif': Read a PPD 
for 'GD-Image-AnimatedGif',</FONT></DIV>
<DIV><FONT size=2>but it is not intended for this build of Perl 
<MSWin32-x86-multi-thread></FONT></DIV>
<DIV><FONT size=2></FONT> </DIV>
<DIV><FONT size=2>PPM></FONT></DIV>
<DIV><FONT size=2></FONT> </DIV>
<DIV><FONT size=2>I use ActiveState ActivePerl 5.6.1.638 with Windows XP. So, 
how can I solve this GD::Image problem?</FONT></DIV>
<DIV><FONT size=2></FONT> </DIV>
<DIV><FONT size=2>Thanks a lot for your help and have a nice 
day<BR>Akio</FONT></DIV>
<DIV><FONT size=2></FONT> </DIV>
<BLOCKQUOTE 
style="PADDING-RIGHT: 0px; PADDING-LEFT: 5px; MARGIN-LEFT: 5px; BORDER-LEFT: #000000 2px solid; MARGIN-RIGHT: 0px">
  <DIV style="FONT: 10pt arial">----- Original Message ----- </DIV>
  <DIV 
  style="BACKGROUND: #e4e4e4; FONT: 10pt arial; font-color: black"><B>From:</B> 
  <A title=d@tucny.com href="mailto:d@tucny.com">D Tucny</A> </DIV>
  <DIV style="FONT: 10pt arial"><B>To:</B> <A title=thy@42.dk 
  href="mailto:thy@42.dk">Kristian Thy</A> </DIV>
  <DIV style="FONT: 10pt arial"><B>Cc:</B> <A title=dev@openstreetmap.org 
  href="mailto:dev@openstreetmap.org">dev@openstreetmap.org</A> </DIV>
  <DIV style="FONT: 10pt arial"><B>Sent:</B> Sunday, April 22, 2007 10:30 
  AM</DIV>
  <DIV style="FONT: 10pt arial"><B>Subject:</B> Re: [OSM-dev] Problems with <A 
  href="mailto:Tiles@Home">Tiles@Home</A> under Windows</DIV>
  <DIV><BR></DIV>On 22/04/07, <B class=gmail_sendername>Kristian Thy</B> <<A 
  href="mailto:thy@42.dk">thy@42.dk</A>> wrote: 
  <DIV><SPAN class=gmail_quote></SPAN>
  <BLOCKQUOTE class=gmail_quote 
  style="PADDING-LEFT: 1ex; MARGIN: 0pt 0pt 0pt 0.8ex; BORDER-LEFT: rgb(204,204,204) 1px solid">On 
    Sun, Apr 22, Hansen wrote:<BR>> thank you for your help. 7-Zip is now 
    working perfect! I only added<BR>> "Zip=C:\7-Zip\7z.exe" to the 
    tileAtHome.conf. But then I have two other<BR>> problems. One is 
    "pngcrush" <BR><BR>As far as I can tell pngcrush isn't mandatory, but you 
    can just dump the<BR>exe file from<BR><A 
    href="http://mesh.dl.sourceforge.net/sourceforge/pmt/pngcrush-1.6.4-win32.zip ">http://mesh.dl.sourceforge.net/sourceforge/pmt/pngcrush-1.6.4-win32.zip 
    </A><BR>into your t@h folder to get it working. I also had to change line 
    802 in<BR>tilesGen.pl 
    from<BR><BR>        my $Cmd = 
    sprintf("%s ./lines2curves.pl %s > 
    %s",<BR><BR>to<BR><BR>        my 
    $Cmd = sprintf("%s perl lines2curves.pl %s > %s",<BR><BR>in order to get 
    t@h running.</BLOCKQUOTE>
  <DIV><BR><BR>I use the $Bin variable in here to fix mine... <BR></DIV><BR>
  <BLOCKQUOTE class=gmail_quote 
  style="PADDING-LEFT: 1ex; MARGIN: 0pt 0pt 0pt 0.8ex; BORDER-LEFT: rgb(204,204,204) 1px solid">> 
    and the other one is "GD::Image".<BR><BR>I think I installed this using the 
    ActiveState PPM, but I can't remember<BR>to be honest :) At any rate, I 
    still get a lot of errors as well:</BLOCKQUOTE>
  <DIV><BR>I got this using ppm too... <BR><BR></DIV>
  <BLOCKQUOTE class=gmail_quote 
  style="PADDING-LEFT: 1ex; MARGIN: 0pt 0pt 0pt 0.8ex; BORDER-LEFT: rgb(204,204,204) 1px solid">This 
    is version 2610 (Frederikssund) of tilesgen running on MSWin32 
    <BR>[#1   0% jobinit] Doing tileset 2185,1274 (area around 
    56.047421,12.084961)<BR>[#1   0% default] Beziercurvehinting zoom 
    level 12... ERROR<BR>  The following command produced an error 
    message:<BR>   perl lines2curves.pl 
    c:\temp\osm\output-3408-z12.svg-temp.svg > 
    c:\temp\osm\output-3408-z12.svg<BR>  Debug output 
    follows:<BR>  | "terse" is not defined in %Math::Vec::EXPORT_TAGS 
    at lines2curves.pl line 47<BR>  |     
    main::BEGIN() called at C:/Perl/site/lib/Math/Vec.pm line 47 
    <BR>  |     eval {...} called at 
    C:/Perl/site/lib/Math/Vec.pm line 47<BR>  | Can't continue after 
    import errors at lines2curves.pl line 47<BR>  | BEGIN 
    failed--compilation aborted at lines2curves.pl line 47.<BR>[#1   
    0% default] Error on Bezier Curve hinting, rendering without bezier curves 
    <BR><BR>I get this for each zoom layer; it's rendered to SVG but 
    without<BR>Beziers. Then, when it comes to doing the PNGs:</BLOCKQUOTE>
  <DIV><BR><BR>That's fixable by installing a more recent Math::Vec from <A 
  title=http://theoryx5.uwinnipeg.ca/ppms/ 
  href="http://theoryx5.uwinnipeg.ca/ppms/">http://theoryx5.uwinnipeg.ca/ppms/</A><BR>(add 
  this as a repository in the ppm tool) </DIV><BR>
  <BLOCKQUOTE class=gmail_quote 
  style="PADDING-LEFT: 1ex; MARGIN: 0pt 0pt 0pt 0.8ex; BORDER-LEFT: rgb(204,204,204) 1px solid">[#1   
    0% default] Splitting c:\temp\osm\/3408.png_part (1 x 1)... Can't<BR>use an 
    undefined value as a symbol reference at 
    C:/Perl/site/lib/GD/Image.pm<BR>line 175.<BR><BR>... at which point it 
  stops.</BLOCKQUOTE>
  <DIV><BR>What version of GD do you have installed? <BR></DIV><BR>d</DIV><BR>
  <P>
  <HR>

  <P></P>_______________________________________________<BR>dev mailing 
  list<BR>dev@openstreetmap.org<BR>http://lists.openstreetmap.org/cgi-bin/mailman/listinfo/dev<BR></BLOCKQUOTE>
<P>
<HR>

<P></P>_______________________________________________<BR>dev mailing 
list<BR>dev@openstreetmap.org<BR>http://lists.openstreetmap.org/cgi-bin/mailman/listinfo/dev<BR></BODY></HTML>