<html xmlns:v="urn:schemas-microsoft-com:vml" xmlns:o="urn:schemas-microsoft-com:office:office" xmlns:w="urn:schemas-microsoft-com:office:word" xmlns:m="http://schemas.microsoft.com/office/2004/12/omml" xmlns="http://www.w3.org/TR/REC-html40"><head><meta http-equiv=Content-Type content="text/html; charset=us-ascii"><meta name=Generator content="Microsoft Word 14 (filtered medium)"><style><!--
/* Font Definitions */
@font-face
        {font-family:"Cambria Math";
        panose-1:2 4 5 3 5 4 6 3 2 4;}
@font-face
        {font-family:Calibri;
        panose-1:2 15 5 2 2 2 4 3 2 4;}
/* Style Definitions */
p.MsoNormal, li.MsoNormal, div.MsoNormal
        {margin:0in;
        margin-bottom:.0001pt;
        font-size:11.0pt;
        font-family:"Calibri","sans-serif";}
a:link, span.MsoHyperlink
        {mso-style-priority:99;
        color:blue;
        text-decoration:underline;}
a:visited, span.MsoHyperlinkFollowed
        {mso-style-priority:99;
        color:purple;
        text-decoration:underline;}
span.EmailStyle17
        {mso-style-type:personal-compose;
        font-family:"Calibri","sans-serif";
        color:windowtext;}
.MsoChpDefault
        {mso-style-type:export-only;
        font-family:"Calibri","sans-serif";}
@page WordSection1
        {size:8.5in 11.0in;
        margin:1.0in 1.0in 1.0in 1.0in;}
div.WordSection1
        {page:WordSection1;}
--></style><!--[if gte mso 9]><xml>
<o:shapedefaults v:ext="edit" spidmax="1026" />
</xml><![endif]--><!--[if gte mso 9]><xml>
<o:shapelayout v:ext="edit">
<o:idmap v:ext="edit" data="1" />
</o:shapelayout></xml><![endif]--></head><body lang=EN-US link=blue vlink=purple><div class=WordSection1><p class=MsoNormal>Hi,<o:p></o:p></p><p class=MsoNormal><o:p> </o:p></p><p class=MsoNormal>I have implemented changeset upload functionality into our editor and it mostly works just fine. I am now testing the edge cases when users would upload “larger” changesets and I am running maybe into some timeout issues that I not quite sure how to handle.<o:p></o:p></p><p class=MsoNormal><o:p> </o:p></p><p class=MsoNormal>For development purposes I am currently using the dev server at <a href="http://api06.dev.openstreetmap.org">http://api06.dev.openstreetmap.org</a> and hitting the /api/0.6/changeset/<id>/upload endpoint.<o:p></o:p></p><p class=MsoNormal>Uploading changesets containing about 50 elements takes about 4 seconds and 500 elements take about 30 seconds. In attempting to upload about 5000 elements I don’t get an answer within an hour and the server automatically closing the changeset (due to idle time against the API).<o:p></o:p></p><p class=MsoNormal><o:p> </o:p></p><p class=MsoNormal>I am well beyond the server advertised timeout of 300 seconds with waiting for my upload post of 5000 features to complete, and the server is already closing the changeset.<o:p></o:p></p><p class=MsoNormal><o:p> </o:p></p><p class=MsoNormal>Is that the expected behavior or asked differently, what is the recommended strategy for uploading larger changesets to the server?<o:p></o:p></p><p class=MsoNormal><o:p> </o:p></p><p class=MsoNormal>Thanks,<o:p></o:p></p><p class=MsoNormal>- Thomas<o:p></o:p></p><p class=MsoNormal><o:p> </o:p></p></div></body></html>