<div dir="ltr"><div dir="ltr">Yes, it seems that style.xml has problems. I can see that on logs when starting renderd. Maybe problem connecting to database. <div><div><div><br></div><div>"</div><div>An error occurred while loading the map layer 'default': Postgis Plugin: FATAL:  role "www-data" does not exist#012Connection string: ' dbname=gis connect_timeout=4'#012  encountered during parsing of layer 'landcover-low-zoom' in Layer at line 691 of '/home/tileserver/src/openstreetmap-carto/style.xml'</div></div><div>"</div></div><div><br></div><div>I just don´t understand how does former tiles were rendering!? <br></div><div><br></div><div>I may have overwriten style files...</div><div><br></div><div><div><br></div></div><div><br></div><div> <div><br></div><div><br></div><div><div><div><br></div><div><br><br></div></div></div></div></div></div><br><div class="gmail_quote"><div dir="ltr">Em sex, 7 de dez de 2018 às 15:45, Kojo <<a href="mailto:rbsnkjmr@gmail.com">rbsnkjmr@gmail.com</a>> escreveu:<br></div><blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex"><div dir="ltr"><div dir="ltr"><div dir="ltr">Jochen, Yves, </div><div dir="ltr">thanks for your attention.<div><br></div><div>When I stop rendered:</div><div><br></div><div><div>root@abcdef:/# ps -ef | grep renderd</div><div>root      40901  38529  0 15:24 pts/0    00:00:00 grep --color=auto renderd</div></div><div><br></div><div><br></div><div>And I request HTTP to clean a tile, it still answer:<br></div><div><span style="color:rgb(0,0,0);white-space:pre-wrap">"Tile submitted for rendering"</span><br></div><div><span style="color:rgb(0,0,0);white-space:pre-wrap"><br></span></div><div><span style="color:rgb(0,0,0);white-space:pre-wrap">And when I ask for tile´s status:</span></div><div><pre style="color:rgb(0,0,0);white-space:pre-wrap">Tile is clean. Last rendered at Thu Dec 06 19:37:30 2018. Last accessed at Fri Dec 07 12:56:14 2018. Stored in file:///var/lib/mod_tile/default/14/0/33/223/20/0.meta
(Dates might not be accurate. Rendering time might be reset to an old date for tile expiry. Access times might not be updated on all file systems)</pre><pre style="color:rgb(0,0,0);white-space:pre-wrap"><br></pre><pre><span style="color:rgb(0,0,0);white-space:normal"><font face="Arial, Helvetica, sans-serif">I thought that renderd was in charge to answer for Apache ModTiles, but I stoped renderd, restarted Apache but dirty/status stills answer. </font></span>And still nothing changes to applying style.</pre></div><div>Andy, I am reading lots of documents. I will check those too. </div><div><br></div><div>Thank you,</div><div>Koji</div><div><br></div><div><br></div><div><br></div><div><br></div><div><br></div><div><br></div><div><blockquote class="gmail_quote" style="margin:0px 0px 0px 0.8ex;border-left:1px solid rgb(204,204,204);padding-left:1ex">> - renderd.conf XML property, points to a style file. I change this file but<br>> the changes I made doesn´t show on tiles, even if I reload data to<br>> database, and even if I mark the tile as "dirty" to force re-render. This<br>> is the reason for the first question, that I can not even understand when<br>> the style is applied, during import, or during render.<br><br>Not sure but you might have to restart renderd and/or apache when<br>changing the renderd config.</blockquote><div><br></div><div> </div></div><div><br></div><br><div class="gmail_quote"><div dir="ltr">Em sex, 7 de dez de 2018 às 14:03, Jochen Topf <<a href="mailto:jochen@remote.org" target="_blank">jochen@remote.org</a>> escreveu:<br></div><blockquote class="gmail_quote" style="margin:0px 0px 0px 0.8ex;border-left:1px solid rgb(204,204,204);padding-left:1ex">On Fri, Dec 07, 2018 at 01:36:32PM -0200, Kojo wrote:<br>
> Here I have some questions:<br>
> - I am using mapnik to style the maps, but it is not clear for me that the<br>
> style is applied  while importing data from osm to database (and stored<br>
> inside db data), or when the tile is rendered.<br>
<br>
Styles are applied when rendering *not* when importing.<br>
<br>
> - renderd.conf XML property, points to a style file. I change this file but<br>
> the changes I made doesn´t show on tiles, even if I reload data to<br>
> database, and even if I mark the tile as "dirty" to force re-render. This<br>
> is the reason for the first question, that I can not even understand when<br>
> the style is applied, during import, or during render.<br>
<br>
Not sure but you might have to restart renderd and/or apache when<br>
changing the renderd config.<br>
<br>
> - I tryed to check the png data direct on disk, but I couldn´t find it<br>
<br>
Tiles are stored as "meta-tiles" on disk, one meta-tile contains 8x8<br>
tiles. This might have thrown your calculations off.<br>
<br>
Jochen<br>
-- <br>
Jochen Topf  <a href="mailto:jochen@remote.org" target="_blank">jochen@remote.org</a>  <a href="https://www.jochentopf.com/" rel="noreferrer" target="_blank">https://www.jochentopf.com/</a>  +49-351-31778688<br>
</blockquote></div></div></div></div>
</blockquote></div>