[josm-dev] Plugins not working with 3094 and Linux ?

Dirk Stöcker openstreetmap at dstoecker.de
Wed Mar 10 10:46:11 GMT 2010

On Wed, 10 Mar 2010, Pieren wrote:

>> JOSM core is already compiled using JAVA6, but still using JAVA5 as
>> target.
> Is it the reason why the plugins compiled with Java5 raises this exception
> on some platforms ?
> Exception is :
> java.lang.
> UnsupportedClassVersionError: Bad version number in .class file
>        at java.lang.ClassLoader.defineClass1(Native Method)
> Anyway, I recompiled my plugin with java6 and it seems to work now.

Don't ask me. I'm no Java guru :-) Maybe you already use JAVA6 stuff in 
your plugin? E.g. isEmpty() in strings?

Or we have such thing in JOSM core and didn't recognice it?

http://www.dstoecker.eu/ (PGP key available)

More information about the josm-dev mailing list