[josm-dev] JMapViewer versioning/backwards compatibility

Matt Hoover the.one.eleven at gmail.com
Fri May 3 08:31:25 UTC 2013


On Sun, Apr 28, 2013 at 9:26 AM, Dirk Stöcker <openstreetmap at dstoecker.de>wrote:

> On Sun, 28 Apr 2013, Felix Natter wrote:
>
>  One concern is: Could you consider making JMapViewer releases with
>> version numbers?  That would make the Debian packaging easier / more
>> meaningful.
>>
>
> Hmm. Open a ticket in JOSM ticket system. There is a JMapViewer component.
> Thought like for josm I would vote to simply use the SVN number.
>
>
That seems like a reasonable solution to me too.  I am unsure what changes
we could/should (?) make to JMapViewer on our end to "include" this version
number.  It is already available via the SVN.  Does it need to be hard
coded into binary releases somehow, or is it sufficient for the people
including it in Debian to know to use the SVN number?


More information about the josm-dev mailing list