[Mailman] Update Mailman to 2.1.19

Tom Hughes tom at compton.nu
Thu Apr 28 09:46:00 UTC 2016


On 28/04/16 10:05, Dirk Stöcker wrote:

> I'm currently in the process of implementing DKIM and DMARC and noticed,
> that OSM mailinglists, especially josm-dev in my case, break correct
> signatures.

You mean they correctly implement decades old email protocols and don't 
attempt to force the world to abandon mail forwarding by coercion?

DKIM and DMARC by design do not allow email forwarding. Unfortunately 
for their designers there is an entire world out there that relies on 
exactly that, and that doesn't change just because you announce that it 
should. They are basically broken by design.

> Would it be possible to update to version 2.1.19 of the mailman software
> which allows better settings to work properly with signed messages?

We run mailman as packaged by Ubuntu so absolutely nothing will happen 
until we're running a version of Ubuntu that has a newer mailman.

Even then I personally would be against changing the setting in question 
though no doubt I will have to do so :-(

Tom

-- 
Tom Hughes (tom at compton.nu)
http://compton.nu/



More information about the mailman mailing list