[Merkaartor] X Error: RenderBadGlyphSet ?

Arnd Baecker arnd.baecker at web.de
Thu Apr 23 09:10:56 BST 2009


On Thu, 23 Apr 2009, Chris Browet wrote:

> Could you all tell me your:
> - Qt version
4.4.3  (4.4.3-0ubuntu1~hardy1~ppa1)

> - X version
1:7.3+10ubuntu10.2

> - Graphic chipset + X driver + version

lspci gives:
00:02.1 Display controller: Intel Corporation Mobile 945GM/GMS/GME,
943/940GML

Looking at /var/log/Xorg.0.log      gives:
intel: Driver for Intel Integrated Graphics Chipsets: i810,

Thanks a lot for looking into this!


Best, Arnd

> Please.

> Thanks
>
> (I obviously never experienced this, but I'm mostly testing Linux thru VNC
> or the Cygwin X server, so I'm 80% sure it is a Qt/X/driver issue)
>
> 2009/4/23 Arnd Baecker <arnd.baecker at web.de>
>
> > On Thu, 23 Apr 2009, Chris Browet wrote:
> >
> > > Looks like there is some reports regarding Qt and threads relating to
> > this.
> > >
> > > Could you confirm it happens to you when the Yahoo! background is
> > activated?
> >
> > It happens both when Yahoo! is activated and also when it is not
> > activated.
> > (hmm, just got a crash while just testing this;
> > I also had one yesterday; presumably I should built a debug
> > version to provide proper backtraces ...)
> >
> > Thanks a lot, Arnd
> >
> >
> >
> > > Thx
> > > - Chris -
> > >
> > > 2009/4/22 Arnd Baecker <arnd.baecker at web.de>
> > >
> > > > On Wed, 22 Apr 2009, Akkana Peck wrote:
> > > >
> > > > > Arnd Baecker writes:
> > > > > > Hi,
> > > > > >
> > > > > > with current svn I almast always encounter
> > > > > >   X Error: RenderBadGlyphSet (invalid GlyphSet parameter) 184
> > > > > > which renders the whole application unuseable,
> > > > > > because no text is displayed.
> > > > > > Surprisingly, this does not happen everytime, eg
> > > > > > from time to time I get a normal looking and useable merkaartor.
> > > > > >
> > > > > > To me this sounds similar (or even the same?) as
> > > > > >
> > http://article.gmane.org/gmane.linux.debian.devel.bugs.general/559816
> > > > > > https://bugzilla.redhat.com/show_bug.cgi?id=495182
> > > > > >
> > > > > > I am using Qt 4.4.3.
> > > > >
> > > > > I have the same problem, on Ubuntu 8.04 and 8.10 -- reported it
> > > > > here several weeks ago,
> > > > >
> > > >
> > http://lists.openstreetmap.org/pipermail/merkaartor/2009-March/001478.html
> > > >
> > > > Hmm, as a follow-up to the discussion there:
> > > > I am not sure that this is a X server problem, because
> > > > a) I have been using a previous 0.13-svn version without any issues
> > > >   before on the same machine (kubuntu 8.04)
> > > > b) As it sometimes does work, I can even have one properly
> > > >   working merkaartor and one disfunctional merkaartor
> > > >   at the same time ..
> > > >
> > > > > It unfortunately makes 0.13 unusable.  I had to go back to 0.12. :-(
> > > > > (Which may not work now that OSM has switched to the 0.6 protocol.)
> > > >
> > > >
> > > > Best, Arnd
> > > >
> > > > _______________________________________________
> > > > Merkaartor mailing list
> > > > Merkaartor at openstreetmap.org
> > > > http://lists.openstreetmap.org/listinfo/merkaartor
> > > >
> > >
> >
>




More information about the Merkaartor mailing list