[Merkaartor] X Error: RenderBadGlyphSet ?

Arnd Baecker arnd.baecker at web.de
Fri Apr 24 12:25:29 BST 2009


On Fri, 24 Apr 2009, Chris Browet wrote:

> I upgraded the netbook to ubuntu 9.04 (=qt 4.5.0) and cannot reproduce
> anymore.
>
> Be it that or something else in 8.10, that seems the way to go.
>
> Could at least one of you upgrade and confirm?

I can't because I am running 8.04 (long time support) on
a "production" machine.

However, it should be possible that I install Qt 4.5 to
a separate place and make merkaartor use that...
I will report back on this hopefully during the next days...

Best, Arnd

> - Chris -
>
> 2009/4/24 Chris Browet <cbro at semperpax.com>
>
> > Ok, the good news is that I can reproduce on my netbook.
> >
> > Working on it ....
> >
> > 2009/4/22 Arnd Baecker <arnd.baecker at web.de>
> >
> >> Hi,
> >>
> >>
> >> with current svn I almast always encounter
> >>  X Error: RenderBadGlyphSet (invalid GlyphSet parameter) 184
> >> which renders the whole application unuseable,
> >> because no text is displayed.
> >> Surprisingly, this does not happen everytime, eg
> >> from time to time I get a normal looking and useable merkaartor.
> >>
> >> To me this sounds similar (or even the same?) as
> >> http://article.gmane.org/gmane.linux.debian.devel.bugs.general/559816
> >> https://bugzilla.redhat.com/show_bug.cgi?id=495182
> >>
> >> I am using Qt 4.4.3.
> >>
> >> Any ideas how to solve this issue?
> >>
> >> Best, Arnd
> >>
> >>
> >> _______________________________________________
> >> Merkaartor mailing list
> >> Merkaartor at openstreetmap.org
> >> http://lists.openstreetmap.org/listinfo/merkaartor
> >>
> >
> >
>




More information about the Merkaartor mailing list