[Merkaartor] 0.14-PRE1 and authenticating proxy support

Chris Browet cbro at semperpax.com
Thu Jul 2 16:25:05 BST 2009


Do you have to problem with all downloads (i.e. OSM, mapnick, yahoo) or only
some? I had problems with 4.5.x, but only with Yahoo (=webkit)

- Chris -

2009/7/2 Thomas Siegmund <siegmund at develogen.com>

> Hi everybody,
>
>
> I'm having problems with proxies too, using current svn builds on linux and
> Qt 4.5.2. A few months ago everything was fine, but unfortunately I do not
> no when the problems started.
>
>
> I have modified line 376/7 in src/Preferences/MerkaartorPreferences.cpp to
> read
>
>
> #if QT_VERSION > 0x040500
> proxy.setType(QNetworkProxy::HttpCachingProxy);
>
>
> and then tried HttpCachingProxy, HttpProxy and Socks5Proxy. Both HttpProxy
> and HttpCachingProxy fail here because they issue a "CONNECT" which the
> proxy does not accept. If I understand the Qt documentation
> http://doc.trolltech.com/4.5/qnetworkproxy.html right, only the HttpProxy
> should use CONNECT. The Socks5Proxy works for me using an ssh tunnel
> bypassing the proxy.
>
>
> The proxy setup code in MerkaartorPreferences looks pretty much like the
> example code in the Qt documentation. For reference I have also looked into
> KDEs Marble, which has started to work here with the latest version. Before
> it failed on the proxy too.
>
>
> http://lxr.kde.org/source/KDE/kdeedu/marble/src/marble_part.cpp
>
>
> It now loads the same tiles which Merkaartor failes to load in it's
> download dialog. Marble uses a HttpProxy, but I don't see much difference in
> the code.
>
>
> Puzzled,
>
>
> Thomas
>
>
> Fabien wrote:
> > Martin Feuersänger <m <at> feuersaenger.de> writes:
> > > Hi all,
> > >
> > > I tried out 0.14-PRE1 yesterday, for the first time on Windows (using
> the
> > > prebuild debug version).
> > > However, I was behind a Microsoft ISA 2006 proxy. I gave hostname,
> port,
> > > username, and password to merkaartor but I only got a "http request
> > > failed" when trying to download.
> >
> > Hi,
> >
> > Proxy error too on SQUID 2.5 and no auth.
> > Works fine with JOSM.
> >
> > Fabien
> >
> >
> >
> >
> > _______________________________________________
> > Merkaartor mailing list
> > Merkaartor at openstreetmap.org
> > http://lists.openstreetmap.org/listinfo/merkaartor
>
>
>
>
> _______________________________________________
> Merkaartor mailing list
> Merkaartor at openstreetmap.org
> http://lists.openstreetmap.org/listinfo/merkaartor
>
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.openstreetmap.org/pipermail/merkaartor/attachments/20090702/7da83e94/attachment.html>


More information about the Merkaartor mailing list