[Merkaartor] Segmentation fault while uploading changes

Manuel Reimer Manuel.Spam at nurfuerspam.de
Sat Jun 5 16:36:25 BST 2010

Chris Browet wrote:
> Yes, it does help, thanks. I tried to reproduce you "remove building" issue
> without success.

I tried, too. Today, I had this problem, again, while drawing a new 
area. Then I recognized having created a point at wrong location and 
"walked back" using Ctrl+Z. The lines were removed, but one point was left.

As the point, that was still left, was at the right postion, I decided 
to "recycle" this point, but now uploading was impossible, Merkaartor 
displayed a message, that there is a conflict that has to be solved, 
where both, the area, I created by recycling this point and the recycled 
point itself, were involved. I had to remove the building, which used 
this "zombie point", first. Then, I tried to remove the point, which 
failed, again. Then upload succeeded, but.... Merkaartor crashed with 

After this, I tried to reproduce creating those "zombie points" several 
times without success.

> Now, assuming your latest crash has nothing to do with "way sharing node",
> and seeing it is the same as the first one, I tend to think the crash has
> nothing (or little) to do with your first issue.

For me, it definetly seems to have to do something with the first issue. 
I always get those crashes while uploading, if, for some reason, points 
aren't properly removed.

For me it seems like those points are left in Merkaartors datasource, 
but in an invalid/incomplete state.



More information about the Merkaartor mailing list