[Merkaartor] cannot upload changes

Boris Cornet borisC at osm-at.org
Wed May 30 11:49:08 BST 2012


Hi Chris!

Until then:
changing the address to
  http://api.openstreetmap.org:80/api/0.6
resolves the problem (mind the port number).

Today (Wednesday, May 30, 2012) at 12:26 you noted:
> Yeah. The bug was corrected in 0.18.

> As I said, I'll produce a 0.18 this week.

> - Chris -


> On 30 May 2012 12:09, Boris Cornet <borisC at osm-at.org> wrote:
> Hello!

> I have the same problem with merkaartor 0.17.2 win. Therefore I have
> tried to find the reason by using Fiddler (a HTTP sniffer proxy), and
> miraculously it worked.

> However Fiddler reports
>  Fiddler has detected a protocol violation in session #8.

>  The Request's Host header did not match the URL's host component.

>  URL Host:       api.openstreetmap.org
>  Header Host:    api.openstreetmap.org:P

> I think I remember a ticket targeting this bug way back. Seems that
> some remnants of the bug have survived, and are now playing tricks on
> us.

> It seems that we urgently need v0.17.3, or at least a recent nightly
> build for windows.

> The day before yesterday (Monday, May 28, 2012) Christian Kraemer typed:
>> Hello,

>> when I try to upload changes I get an error message, saying that "The
>> requested URL /api/0.6/changeset/<changeset_number>/upload was not
>> found on this server.".
>> Is it just me, a temporarily problem or a change in the API, which
>> Merkaartor 0.17.2 can't handle?

>> Greetings Christian



> --
> Good Bye,
>   Boris


> _______________________________________________
> Merkaartor mailing list
> Merkaartor at openstreetmap.org
> http://lists.openstreetmap.org/listinfo/merkaartor




-- 
Bye Bye,
   Boris




More information about the Merkaartor mailing list