[OSRM-talk] Trying to build OSRM v5.

Daniel Hofmann hofmann at mapbox.com
Sun Apr 24 17:01:22 UTC 2016


-DBUILD_TOOLS does not need gdal from what I can see:

https://github.com/Project-OSRM/osrm-backend/blob/8ec1f0a6ebbd38159e5eb96f0240b2b0757fe4de/CMakeLists.txt#L350-L365

It's only the -DBUILD_COMPONENTS flag that enables the tool for small
components that needs gdal:

https://github.com/Project-OSRM/osrm-backend/blob/8ec1f0a6ebbd38159e5eb96f0240b2b0757fe4de/CMakeLists.txt#L337-L348

That is, this is the error you are seeing:

https://github.com/Project-OSRM/osrm-backend/blob/8ec1f0a6ebbd38159e5eb96f0240b2b0757fe4de/CMakeLists.txt#L346

Please make sure you're actually building the latest v5 release.

In addition, the warnings at the bottom come from using gcc 4.8 which has
some issues (amongst other issues, its link time optimization is broken).
For production use you may want to update your compiler.

Cheers,
Daniel J H

On Sun, Apr 24, 2016 at 12:32 AM, James Grant <james at grantzone.net> wrote:

> Hi there.
>
> I'm currently building the latest version of OSRM and when going through
> the build commands, I'm noticing the following errors:
>
> root at Dell-Poweredge-860:/osrm5/osrm-backend/build# cmake ..
> -DCMAKE_BUILD_TYPE=Release -DBUILD_TOOLS=1
> -- The C compiler identification is GNU 4.8.4
> -- The CXX compiler identification is GNU 4.8.4
> -- Check for working C compiler: /usr/bin/cc
> -- Check for working C compiler: /usr/bin/cc -- works
> -- Detecting C compiler ABI info
> -- Detecting C compiler ABI info - done
> -- Check for working CXX compiler: /usr/bin/c++
> -- Check for working CXX compiler: /usr/bin/c++ -- works
> -- Detecting CXX compiler ABI info
> -- Detecting CXX compiler ABI info - done
> -- Building on a 64 bit system
> -- Configuring OSRM in release mode
> -- Performing Test LTO_AVAILABLE
> -- Performing Test LTO_AVAILABLE - Success
> -- Performing Test LTO_WORKS
> -- Performing Test LTO_WORKS - Success
> -- LTO working
> -- Disabling LTO on GCC < 4.9.0 since it is broken, see:
> https://gcc.gnu.org/bugzilla/show_bug.cgi?id=57038
> -- Performing Test HAS_COLOR_FLAG
> -- Performing Test HAS_COLOR_FLAG - Failed
> -- Setting linker optimizations
> -- Found ZLIB: /usr/lib/x86_64-linux-gnu/libz.so (found version "1.2.8")
> -- Looking for include file pthread.h
> -- Looking for include file pthread.h - found
> -- Looking for pthread_create
> -- Looking for pthread_create - not found
> -- Looking for pthread_create in pthreads
> -- Looking for pthread_create in pthreads - not found
> -- Looking for pthread_create in pthread
> -- Looking for pthread_create in pthread - found
> -- Found Threads: TRUE
> -- Found EXPAT: /usr/lib/x86_64-linux-gnu/libexpat.so (found version
> "2.1.0")
> -- Found BZip2: /usr/lib/x86_64-linux-gnu/libbz2.so (found version
> "1.0.6")
> -- Looking for BZ2_bzCompressInit in /usr/lib/x86_64-linux-gnu/libbz2.so
> -- Looking for BZ2_bzCompressInit in /usr/lib/x86_64-linux-gnu/libbz2.so -
> found
> -- Found Osmium: /osrm5/osrm-backend/third_party/libosmium/include
> -- Boost version: 1.54.0
> -- Found the following Boost libraries:
> --   date_time
> --   filesystem
> --   iostreams
> --   program_options
> --   regex
> --   system
> --   thread
> -- Found Intel TBB
> -- Looking for Luabind...
> -- Found Luabind: /usr/lib/libluabind.so
> -- Found Luabind: /usr/lib/libluabind.so
> -- Found Lua52: /usr/lib/x86_64-linux-gnu/liblua5.2.so;/usr/lib/x86_64-linux-gnu/libm.so
>
> -- Looking for LuaJIT 5.2
> -- Could NOT find LUAJIT (missing:  LUAJIT_LIBRARIES)
> -- Performing Test LUABIND_WORKS
> -- Performing Test LUABIND_WORKS - Success
> -- Luabind/Lua5.2 combination working with /usr/lib/x86_64-linux-gnu/
> liblua5.2.so
> -- Looking for STXXL...
> -- Found STXXL: /usr/lib/libstxxl.so
> -- Found STXXL: /usr/lib/libstxxl.so
> -- Try OpenMP C flag = [-fopenmp]
> -- Performing Test OpenMP_FLAG_DETECTED
> -- Performing Test OpenMP_FLAG_DETECTED - Success
> -- Try OpenMP CXX flag = [-fopenmp]
> -- Performing Test OpenMP_FLAG_DETECTED
> -- Performing Test OpenMP_FLAG_DETECTED - Success
> -- OpenMP support found. Linking just in case for stxxl
> -- Could NOT find GDAL (missing:  GDAL_LIBRARY GDAL_INCLUDE_DIR)
> CMake Warning at CMakeLists.txt:346 (message):
>   libgdal and/or development headers not found
>
>
> -- Activating OSRM internal tools
> -- Could NOT find Doxygen (missing:  DOXYGEN_EXECUTABLE)
> -- Boost version: 1.54.0
> -- Found the following Boost libraries:
> --   unit_test_framework
> -- Configuring done
> -- Generating done
> -- Build files have been written to: /osrm5/osrm-backend/build
>
> When I run the next command it gives the errors again shown below, but
> this is simply a snippet of several that I get:
>
> root at Dell-Poweredge-860:/osrm5/osrm-backend/build# cmake --build .
> Scanning dependencies of target CONTRACTOR
> [  0%] Building CXX object
> CMakeFiles/CONTRACTOR.dir/src/contractor/contractor.cpp.o
> [  0%] Built target CONTRACTOR
> Scanning dependencies of target ENGINE
> [  1%] Building CXX object
> CMakeFiles/ENGINE.dir/src/engine/engine_config.cpp.o
> [  3%] Building CXX object CMakeFiles/ENGINE.dir/src/engine/hint.cpp.o
> [  4%] Building CXX object
> CMakeFiles/ENGINE.dir/src/engine/douglas_peucker.cpp.o
> [  6%] Building CXX object CMakeFiles/ENGINE.dir/src/engine/engine.cpp.o
> In file included from /osrm5/osrm-backend/src/engine/engine.cpp:3:0:
> /osrm5/osrm-backend/include/engine/api/route_parameters.hpp: In
> instantiation of
> ‘osrm::engine::api::RouteParameters::RouteParameters(bool, bool,
> osrm::engine::api::RouteParameters::GeometriesType,
> osrm::engine::api::RouteParameters::OverviewType, boost::optional<bool>,
> Args ...) [with Args = {}]’:
> /osrm5/osrm-backend/include/engine/api/match_parameters.hpp:58:29:
> required from here
> /osrm5/osrm-backend/include/engine/api/route_parameters.hpp:80:93:
> warning: missing initializer for member
> ‘osrm::engine::api::BaseParameters::coordinates’
> [-Wmissing-field-initializers]
>            geometries{geometries_}, overview{overview_},
> continue_straight{continue_straight_}
>
> ^
> /osrm5/osrm-backend/include/engine/api/route_parameters.hpp:80:93:
> warning: missing initializer for member
> ‘osrm::engine::api::BaseParameters::hints’
> [-Wmissing-field-initializers]
> /osrm5/osrm-backend/include/engine/api/route_parameters.hpp:80:93:
> warning: missing initializer for member
> ‘osrm::engine::api::BaseParameters::radiuses’
> [-Wmissing-field-initializers]
> /osrm5/osrm-backend/include/engine/api/route_parameters.hpp:80:93:
> warning: missing initializer for member
> ‘osrm::engine::api::BaseParameters::bearings’
> [-Wmissing-field-initializers]
> [  7%] Building CXX object
> CMakeFiles/ENGINE.dir/src/engine/search_engine_data.cpp.o
> [  9%] Building CXX object
> CMakeFiles/ENGINE.dir/src/engine/polyline_compressor.cpp.o
> [ 10%] Building CXX object
> CMakeFiles/ENGINE.dir/src/engine/api/json_factory.cpp.o
> [ 12%] Building CXX object
> CMakeFiles/ENGINE.dir/src/engine/guidance/assemble_overview.cpp.o
> [ 13%] Building CXX object
> CMakeFiles/ENGINE.dir/src/engine/guidance/post_processing.cpp.o
> [ 15%] Building CXX object
> CMakeFiles/ENGINE.dir/src/engine/guidance/assemble_steps.cpp.o
> [ 16%] Building CXX object
> CMakeFiles/ENGINE.dir/src/engine/guidance/assemble_route.cpp.o
> [ 18%] Building CXX object
> CMakeFiles/ENGINE.dir/src/engine/plugins/trip.cpp.o
> [ 19%] Building CXX object
> CMakeFiles/ENGINE.dir/src/engine/plugins/tile.cpp.o
> [ 21%] Building CXX object
> CMakeFiles/ENGINE.dir/src/engine/plugins/match.cpp.o
> In file included from
> /osrm5/osrm-backend/include/engine/api/match_parameters.hpp:31:0,
>                  from
> /osrm5/osrm-backend/include/engine/plugins/match.hpp:5,
>                  from /osrm5/osrm-backend/src/engine/plugins/match.cpp:2:
> /osrm5/osrm-backend/include/engine/api/route_parameters.hpp: In
> instantiation of
> ‘osrm::engine::api::RouteParameters::RouteParameters(bool, bool,
> osrm::engine::api::RouteParameters::GeometriesType,
> osrm::engine::api::RouteParameters::OverviewType, boost::optional<bool>,
> Args ...) [with Args = {}]’:
> /osrm5/osrm-backend/include/engine/api/match_parameters.hpp:58:29:
> required from here
> /osrm5/osrm-backend/include/engine/api/route_parameters.hpp:80:93:
> warning: missing initializer for member
> ‘osrm::engine::api::BaseParameters::coordinates’
> [-Wmissing-field-initializers]
>            geometries{geometries_}, overview{overview_},
> continue_straight{continue_straight_}
>
> ^
> /osrm5/osrm-backend/include/engine/api/route_parameters.hpp:80:93:
> warning: missing initializer for member
> ‘osrm::engine::api::BaseParameters::hints’
> [-Wmissing-field-initializers]
> /osrm5/osrm-backend/include/engine/api/route_parameters.hpp:80:93:
> warning: missing initializer for member
> ‘osrm::engine::api::BaseParameters::radiuses’
> [-Wmissing-field-initializers]
> /osrm5/osrm-backend/include/engine/api/route_parameters.hpp:80:93:
> warning: missing initializer for member
> ‘osrm::engine::api::BaseParameters::bearings’
> [-Wmissing-field-initializers]
> [ 22%] Building CXX object
> CMakeFiles/ENGINE.dir/src/engine/plugins/viaroute.cpp.o
>
> I am trying to compile this on Ubuntu 14.04, anyone have any ideas? I
> haven't taken it further than this so far as I didn't think it would work
> with the errors shown.
>
> Regards
> James.
>
> _______________________________________________
> OSRM-talk mailing list
> OSRM-talk at openstreetmap.org
> https://lists.openstreetmap.org/listinfo/osrm-talk
>
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.openstreetmap.org/pipermail/osrm-talk/attachments/20160424/7ba1405a/attachment.html>


More information about the OSRM-talk mailing list