[OSRM-talk] osrm-extract taking hours to complete

Kieran Caplice kieran.caplice at temetra.com
Wed Mar 2 16:51:51 UTC 2016


Hello,

I'm currently extracting the planet PBF (~31 GB), and it's been running 
for hours. I notice in the "Running OSRM" wiki page, it says " On a Core 
i7 with 8GB RAM and (slow) 5400 RPM Samsung SATA hard disks it took 
about 65 minutes to do so from a PBF formatted planet", which is making 
me wonder why it's taking so long on our server. Below are some example 
output messages:

[info] Parsing finished after 3584.35 seconds
[extractor] Erasing duplicate nodes   ... ok, after 319.091s
[extractor] Sorting all nodes   ... ok, after 3632.87s
[extractor] Building node id map      ... ok, after 2025.29s
[extractor] Confirming/Writing used nodes     ... ok, after 1096.24s
[extractor] Sorting edges by start    ... ok, after 2000.08s

Some stxxl errors were outputted as I set the disk size to 100GB 
thinking it was enough - but I didn't think it would cause such 
slowdowns as this, considering extracting the Europe PBF takes hours 
also without the stxxl errors.

Server specs:
Ubuntu 14.04
Intel Xeon CPU E5-1650 v3 @ 3.50GHz  (hex-core with HT)
64 GB RAM @ 2133 MHz
2 TB Western Digital Enterprise 7200 RPM hard drive

At the moment, disk IO is averaging around 35-40 MB/s R/W (~90%).

Anyone have any ideas as to what might be going on? Or is it normal to 
take this long without an SSD?

Thanks in advance.

Kind regards,
Kieran Caplice

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.openstreetmap.org/pipermail/osrm-talk/attachments/20160302/4566c80a/attachment.html>


More information about the OSRM-talk mailing list