[OSRM-talk] OSRM-talk Digest, Vol 46, Issue 18

Mark Hagers mark at marksman-do.nl
Tue Nov 1 16:03:59 UTC 2016


Hi Daniel,

> On 1 nov. 2016, at 16:48, Daniel Patterson <daniel at mapbox.com> wrote:
> 
>  That sounds like a bug, the behavior should be the same.  Can you open a ticket on GitHub with lots of details (what file you're processing, what version of OSRM, what requests, etc)?


I'll have to research this a bit more. My initial assessment seems to be wrong, the server on windows seems to return a lot less data with the same requests as the server on OSX, regardless of whether the points are snapped to the network or not.
Currently the only service that seems to return any actual data is the nearest service (on windows) the other services return empty data (json structures without any actual content) or the "NoRoute" response.

I've noticed that the directory structure on windows is different from that on OSX. The profiles are in the same dir as the binaries, whereas on OSX the profiles are not included at all in the default homebrew install (I've downloaded the source separately and used the profiles from that in the extract/contract steps)

I'll gladly open a ticket, but I want to make sure I'm not working with an incorrect setup before I do that.

Is there any document describing how to set things up on Windows or is my approach (just unpack the Release zipfile into a directory) the correct procedure? 

best regards,
 
Mark Hagers <mark at marksman-do.nl>

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.openstreetmap.org/pipermail/osrm-talk/attachments/20161101/d0af42a4/attachment.html>


More information about the OSRM-talk mailing list