[OSRM-talk] Building osrm-backend 15.4.2 or 15.4.3 on Ubuntu 14.04

Daniel Hofmann hofmann at mapbox.com
Mon Nov 14 21:52:43 UTC 2016


I just added a note on how to update your compiler:
https://github.com/Project-OSRM/osrm-backend/wiki/Building-on-Ubuntu#ubuntu-1404

And here's how I could just reproduce a osrm v5.4.3 build in a clean Ubuntu
14.04 Docker container:

docker run -it ubuntu:14.04 /bin/bash
apt-get update
apt-get install software-properties-common
add-apt-repository ppa:ubuntu-toolchain-r/test
apt-get update
apt-get install g++-6 gcc-6 build-essential git wget cmake pkg-config
libbz2-dev libstxxl-dev libstxxl1 libxml2-dev libzip-dev libboost-all-dev
lua5.2 liblua5.2-dev libluabind-dev libtbb-dev
export CPP=cpp-6 CC=gcc-6 CXX=g++-6
wget https://github.com/Project-OSRM/osrm-backend/archive/v5.4.3.tar.gz
tar xf v5.4.3.tar.gz
cd osrm-backend-5.4.3/
mkdir build
cd build
cmake ..
make -j 8


HTH,
Daniel J H

On Mon, Nov 14, 2016 at 9:05 PM, Mikey Alexander <
mikey.alexander at streetlightdata.com> wrote:

> Has anyone successfully done this yet?  What path did you take to upgrade
> to the GCC 5 compiler?
>
> _______________________________________________
> OSRM-talk mailing list
> OSRM-talk at openstreetmap.org
> https://lists.openstreetmap.org/listinfo/osrm-talk
>
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.openstreetmap.org/pipermail/osrm-talk/attachments/20161114/c6bd515c/attachment.html>


More information about the OSRM-talk mailing list