[OSRM-talk] Segfault with 5.4.0 osrm-extract and foot.lua

Daniel Hofmann hofmann at mapbox.com
Thu Oct 6 11:55:40 UTC 2016


Another thing to try is using the pre-build binaries we publish to npm for
node-osrm; you can get them via

npm install

then the osrm-* binaries Travis built should be at

node_modules/osrm/lib/binding/

On Thu, Oct 6, 2016 at 1:45 PM, Frederik Ramm <frederik at remote.org> wrote:

> Hi,
>
>    I've re-run with debug enabled but that wasn't much better:
>
> ======= Backtrace: =========
> /lib/x86_64-linux-gnu/libc.so.6(+0x77725)[0x7fd9e4134725]
> /lib/x86_64-linux-gnu/libc.so.6(+0x7ff4a)[0x7fd9e413cf4a]
> /lib/x86_64-linux-gnu/libc.so.6(cfree+0x4c)[0x7fd9e4140abc]
> osrm-extract(_ZN9__gnu_cxx13new_allocatorISt10_List_
> nodeIyEE10deallocateEPS2_m+0xc)[0x988c24]
> osrm-extract(_ZNSt7__cxx1110_List_baseIySaIyEE11_M_put_
> nodeEPSt10_List_nodeIyE+0xe)[0x988c34]
> osrm-extract(_ZNSt7__cxx1110_List_baseIySaIyEE8_M_clearEv+0x1d)[0x988c53]
> osrm-extract(_ZNSt7__cxx1110_List_baseIySaIyEED1Ev+0x9)[0x988c67]
> osrm-extract(_ZNSt7__cxx114listIySaIyEED1Ev+0x9)[0x988c73]
> osrm-extract(_ZN5stxxl9lru_pagerILj8EED1Ev+0x1d)[0x988c93]
> osrm-extract(_ZN5stxxl6vectorIjLj4ENS_9lru_pagerILj8EEELj2097152ENS_
> 2RCEyED1Ev+0xe8)[0x9ad4bc]
> osrm-extract(_ZN4osrm9extractor20ExtractionContainersD1Ev+0x3c)[0x9ae67c]
> osrm-extract(_ZN4osrm9extractor9Extractor3runERNS0_
> 20ScriptingEnvironmentE+0xbc2)[0x9bd03a]
> osrm-extract(main+0x22c)[0x9123cb]
> /lib/x86_64-linux-gnu/libc.so.6(__libc_start_main+0xf0)[0x7fd9e40dd830]
> osrm-extract(_start+0x29)[0x905799]
>
> On 10/06/2016 11:05 AM, Daniel Hofmann wrote:
> > I think we need more details here: first of all, it seems like Ubuntu
> > 16.04 ships Lua5.3 with apt, for which we saw an immense increase in
> > memory usage.
>
> I didn't get any out-of-memory errors. Also I didn't use Lua5.3, I only
> have 5.1 and 5.2:
>
> % dpkg -l |grep lua
> ii  liblua5.1-0:amd64                      5.1.5-8ubuntu1
>             amd64        Shared library for the Lua interpreter version 5.1
> ii  liblua5.1-0-dev:amd64                  5.1.5-8ubuntu1
>             amd64        Development files for the Lua language version 5.1
> ii  liblua5.2-0:amd64                      5.2.4-1ubuntu1
>             amd64        Shared library for the Lua interpreter version 5.2
> ii  liblua5.2-dev:amd64                    5.2.4-1ubuntu1
>             amd64        Development files for the Lua language version 5.2
> ii  libluabind-dev                         0.9.1+dfsg-10
>             amd64        luabind c++ binding for lua: static library and
> headers
> ii  libluabind0.9.1v5                      0.9.1+dfsg-10
>             amd64        luabind c++ binding for lua: runtime library
> ii  lua5.1                                 5.1.5-8ubuntu1
>             amd64        Simple, extensible, embeddable programming
> language
> ii  lua5.2                                 5.2.4-1ubuntu1
>             amd64        Simple, extensible, embeddable programming
> language
>
> and
>
> % ldd /usr/local/bin/osrm-extract |grep lua
>         libluabind.so.0.9.1 => /usr/lib/libluabind.so.0.9.1
> (0x00007f2207e1f000)
>         liblua5.2.so.0 => /usr/lib/x86_64-linux-gnu/liblua5.2.so.0
> (0x00007f2207bed000)
>
> > Then, can you tell us if you're using the default profile or did you
> > make any adjustments to it?
>
> None, using the standard foot.lua supplied with 5.4.0.
>
> I'll try (a) on a 14.04 Ubuntu, (b) with an older OSRM, (c) with a
> differently-produced Europe file to see what happens. Any other ideas
> are welcome.
>
> Bye
> Frederik
>
> --
> Frederik Ramm  ##  eMail frederik at remote.org  ##  N49°00'09" E008°23'33"
>
> _______________________________________________
> OSRM-talk mailing list
> OSRM-talk at openstreetmap.org
> https://lists.openstreetmap.org/listinfo/osrm-talk
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.openstreetmap.org/pipermail/osrm-talk/attachments/20161006/9944f4c5/attachment-0001.html>


More information about the OSRM-talk mailing list