[OSRM-talk] One thread not solving when number of observations is large

Sayer, Bryan BSayer at s-3.com
Fri Jul 14 15:57:24 UTC 2017


Hi,


We are using the Stata wrapper of osrm to find routes for millions of observations. I have finally deduced that one thread does not work when the number of observations is large enough. 5 million is large enough; 1 million is not. The return code is 3=Something else is wrong for exactly 25% of the observations when I specify 4 threads (or allow it to default); 12.5% of the observations when I specify 8 threads. I have four cores with 2 threads each. (I am testing two threads now). I suspect it is the first thread that has a problem, since it is the first observations that do not solve.


Does anyone know what is going on or how to fix this? It almost sounds like the first thread has some other responsibilities that cause problems when there are too many records. But could it be a hardware problem?


Thanks!


Bryan Sayer

Statistician, SSS, Inc.

www.s-3.com

****WARNING**** This information may be confidential. It is intended only for the addressee(s) identified above. If you are not the addressee(s), or an employee or agent of the addressee(s), please note that any dissemination, distribution, or copying of this communication is strictly prohibited. If you have received this information in error, please destroy the information and notify the sender of the error. Thank you.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.openstreetmap.org/pipermail/osrm-talk/attachments/20170714/83fe225d/attachment.html>


More information about the OSRM-talk mailing list