[Potlatch-dev] [OpenStreetMap] #4297: After adding tags in advanced mode and before moving the background, tags mysteriously disappear

OpenStreetMap trac at openstreetmap.org
Wed Mar 14 21:49:51 GMT 2012


#4297: After adding tags in advanced mode and before moving the background, tags
mysteriously disappear
-------------------------+--------------------------------------------------
 Reporter:  SomeoneElse  |       Owner:  potlatch-dev@…                
     Type:  defect       |      Status:  new                           
 Priority:  trivial      |   Milestone:                                
Component:  potlatch2    |     Version:                                
 Keywords:  delete tag   |  
-------------------------+--------------------------------------------------
 (OK, so it's not mysterious now I think I know what's going on)

 In areas that are a bit hilly, there's often a lot of zooming in and out
 and shuffling the background to best fit GPS traces (where it looks like
 the traces are OK and the background's not, which isn't always the case,
 of course).  This can cause tags to disappear in the following way:

 o Go into advanced mode in P2 and add some tags.

 o Press either return or tab from the "value" field.

 o Press the space bar (prior to doing a space-mouse-drag to nudge the
 background slightly)

 o The tag has gone!

 The reason is that tab or return from the tag's "value" field has caused
 "delete" at the bottom to be highlighted, and "space" selects it, deleting
 the tag.

-- 
Ticket URL: <https://trac.openstreetmap.org/ticket/4297>
OpenStreetMap <http://www.openstreetmap.org/>
OpenStreetMap is a free editable map of the whole world



More information about the Potlatch-dev mailing list