[openstreetmap-website] Signup via oauth cycle broken (#307)

Christoph Bünte notifications at github.com
Thu Jun 13 21:48:51 UTC 2013


Ok, let me clarify: On the wheelmap "Sign in" page, there are two links:

* sign in with osm
* register at osm

First link goes to the oauth endpoint: http://www.openstreetmap.org/oauth/authorize?oauth_token=F3D7EPbxJTOAGQNOeO6UeMuJupgRcOtZaAGHGbuw

Second link, which is the one in question, does the following, when clicked: The wheelmap server requests a request token manually and then redirects the user directly to the OSM sign up page with a referer parameter containing the forementioned link to the authorize url which looks like this: https://www.openstreetmap.org/user/new?locale=en&referer=http%3A%2F%2Fwww.openstreetmap.org%2Foauth%2Fauthorize%3Foauth_token%3Db4rdzbGyL6SA9cHi8B6lraWzgR1kxQA40clJlIFi

In fact is it the same as sending the user to the endpoint while not logged in with osm, and the user clicked the "Register now" link on the osm page. So yes, we do send the user to the oauth endpoint, but it was us, not osm redirecting the user to the sign up page.

If there is something wrong with it, let me know. If not, let's fix it :)



---
Reply to this email directly or view it on GitHub:
https://github.com/openstreetmap/openstreetmap-website/issues/307#issuecomment-19427355
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.openstreetmap.org/pipermail/rails-dev/attachments/20130613/482b1710/attachment.html>


More information about the rails-dev mailing list