[openstreetmap-website] Installation issues (#685)

Tom Hughes notifications at github.com
Thu Jan 23 18:00:55 UTC 2014

The very first thing in your original bug report quotes the output from `psql` where you apparently tried to run `structure.sql` and it failed - that is what made me think you had been trying to run it.

The `structure.sql` script is not a test script, it's just documentation effectively. Are you saying that you ran `rake test` and it tried to run `structure.sql`?

Anyway, you migration problem is occurring on the GIST index, which means you most likely forgot to add the `btree_gist` extension before you ran the migrations - see https://github.com/openstreetmap/openstreetmap-website/blob/master/INSTALL.md#postgresql-btree-gist-extension for how to do that.

Reply to this email directly or view it on GitHub:
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.openstreetmap.org/pipermail/rails-dev/attachments/20140123/2de7b507/attachment.html>

More information about the rails-dev mailing list