[OpenStreetMap] #5294: Login using openid does not function after signup

OpenStreetMap trac at noreply.openstreetmap.org
Sat Mar 14 13:36:10 UTC 2015


#5294: Login using openid does not function after signup
-----------------------------------+-------------------------
 Reporter:  arjun.krishna1994@…    |      Owner:  rails-dev@…
     Type:  defect                 |     Status:  new
 Priority:  minor                  |  Milestone:
Component:  website                |    Version:
 Keywords:  OPENID, SINGUP, LOGIN  |
-----------------------------------+-------------------------
 Problem:

 I signed up/registered on the website
 at[https://www.openstreetmap.org/user/new] using google as the third
 party. After that whenever I Tried to use google as the third party for
 login, it says "Your ID is not associated with a OpenStreetMap account
 yet". and redirects me to the signup page instead of logging me in.
 If I proceed with this signup form it says that my email address is
 already taken.
 However if I try to login using my email address and password everything
 works fine.



 Environment:
  Firefox 33.1 on Fedora 21.
  Google Chrome Version 39.0.2171.95 (64-bit) on Fedora 21.


 Steps to Repoduce on the environment:
 1.Signup using google as a third party for an open street maps account.
 2.Logout of the account if you are loggedin.
 3.Try to login again using google as the third party openid  provider.


 Is it just me or is anyone else experiencing the same issue?

--
Ticket URL: <https://trac.openstreetmap.org/ticket/5294>
OpenStreetMap <http://www.openstreetmap.org/>
OpenStreetMap is a free editable map of the whole world



More information about the rails-dev mailing list