[openstreetmap-website] Additional command for postgres headers installation and possible errors (#1192)

Tom Hughes notifications at github.com
Sun Mar 27 09:52:45 UTC 2016


If the header name is only different in postgres 8 then we won't be taking that part of the change as 9.1 is the minimum required version, in part because it makes it a lot easier to document things as there is less variation. Version 9.1 is nearly five years old now so it's hardly an onerous requirement.

I'm also not sure what an `apt-get` command has to do with Arch Linux?

Honestly I don't see anything helpful here at the moment.

If there's a genuine problem then I'd love to solve it, but currently I'm very unclear about exactly what distribution you're using, and what version of Postgres.

If at all possible I would like to avoid conditional instructions, and especially instructions of the form "if this doesn't work then try this" in favour of straightforward lists of things to do, possibly conditionalised on what distribution is in use.

So the first step should be to understand on what distributions the current instructions don't work, and why, so that we can try to find a clean way of improving them.

---
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/openstreetmap/openstreetmap-website/pull/1192#issuecomment-202029639
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.openstreetmap.org/pipermail/rails-dev/attachments/20160327/50db7c5f/attachment.html>


More information about the rails-dev mailing list