[openstreetmap/openstreetmap-website] Cookie_test doesn't always give/show the right result (#1220)

Malou Maris notifications at github.com
Thu May 19 13:16:16 UTC 2016


In an email I got a link to sign up for OpenStreetMap (https://www.openstreetmap.org/user/new?cookie_test=true). The website I got showed the sign up page, as expected, but also a message that I didn't have cookies enabled and I should enable them before going further. I've seen this in both Firefox and Chrome, see the attachment for a screen shot of the website in Chrome. I did have cookies enabled however, and simply changing the url to 'https://www.openstreetmap.org/user/new?cookie_test=false' made the message about cookies go away.

I've tried the same thing with cookies disabled. The same website, with the message about cookies being disabled was shown, and now changing the url to 'https://www.openstreetmap.org/user/new?cookie_test=false' did not make the message go away.

Especially the first case is confusing for people who don't know where to change their cookie preferences and whether they should do that, and even more so because the message shouldn't show when cookies are enabled.

![issue_osm](https://cloud.githubusercontent.com/assets/1774471/15394683/95ac651a-1dd4-11e6-952e-ec3802af2ffe.png)

---
You are receiving this because you are subscribed to this thread.
Reply to this email directly or view it on GitHub:
https://github.com/openstreetmap/openstreetmap-website/issues/1220
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.openstreetmap.org/pipermail/rails-dev/attachments/20160519/c2147539/attachment.html>


More information about the rails-dev mailing list