"Application uninitialized" for a fresh OSM website

Jean-Claude Jouffre jean-claude.jouffre at univ-smb.fr
Tue Nov 22 15:34:49 UTC 2016


I failed to install and run an OSM website, following the installation 
instructions :

I used a docker virtual machine with Ubuntu 14.0.4 and changed a little 
bit the first step :

   apt-get install ruby2.3 libruby2.3 ruby2.3-dev \
                  libmagickwand-dev libxml2-dev libxslt1-dev nodejs \
                  apache2 build-essential git-core \
                  postgresql postgresql-contrib libpq-dev \
                  postgresql-server-dev-all \
                  libsasl2-dev imagemagick

because, after Ubuntu updating (apt-get update + apt-get upgrade)
- I didn't find ruby2.0, so I installed ruby 2.3
- I didnt' find apache2-threaded-dev, so I forgot this package.

When I ran the tests (bundle exec rake test:db)
- the first time, they failed because there was no svgo command
- so I did :
apt-get install npm
npm install -g svgo
ln -s /usr/bin/nodejs /usr/bin/node (workaround of nodejs installation 
- the second time, they were successfull :
1075 runs, 294997 assertions, 0 failures, 0 errors, 0 skips

But when the server starts (bundle exec rails server)
1) there is no error message at the console :
=> Booting WEBrick
=> Rails application starting in development on 
=> Run `rails server -h` for more startup options
=> Ctrl-C to shutdown server
[2016-11-22 16:52:20] INFO  WEBrick 1.3.1
[2016-11-22 16:52:20] INFO  ruby 2.3.1 (2016-04-26) [x86_64-linux-gnu]
[2016-11-22 16:52:20] INFO  WEBrick::HTTPServer#start: pid=1941 port=3000
2) the last line of the log file 
(openstreetmap-website/log/development.log) is :
Application uninitialized: Try calling YourApp::Application.initialize!
3) when I run a web brower the I have an error 
message "The connection was reset"

I have checked that the 2 expected servers are listening :
netstat -ntlp
Active Internet connections (only servers)
Proto Recv-Q Send-Q Local Address           Foreign Address 
State       PID/Program name
tcp        0      0* 
LISTEN      -
tcp        0      0* 
LISTEN      -
tcp6       0      0 ::1:3000                :::* 
LISTEN      -
tcp6       0      0 ::1:5432                :::* 
LISTEN      -

Can you please help me ?
Thanks in advance,


More information about the rails-dev mailing list